Menu

Erreur VALEUR fonction NB.SI.ENS

Messages postés
2
Date d'inscription
lundi 8 avril 2019
Statut
Membre
Dernière intervention
9 avril 2019
- - Dernière réponse : Prune63000
Messages postés
2
Date d'inscription
lundi 8 avril 2019
Statut
Membre
Dernière intervention
9 avril 2019
- 9 avril 2019 à 09:34
Bonjour,

Je transmets une capture de mon tableur en espérant illustrer mon propos :)

Je souhaite sur ma feuille 'Secteur1!' comptabiliser les personnes âgées de 18-24 présent dans la ligne d'âge (C3:DF3) et qui rencontrent des difficultés financières dans le paiement de leurs frais de santé (informations présente en C31:DF35).

Suite au message d'erreur, j'ai pris connaissance de la règle "Chaque plage supplémentaire doit avoir le même nombre de lignes et de colonnes en tant qu’argument plage_critères1. Les plages ne doivent pas nécessairement être adjacentes." C'est pourquoi, j'utilise, suivant les conseils d'un commentaire forum la fonction : =NB.SI.ENS('Secteur 1'!$C$3:$DF$3;"18-24")+NB.SI.ENS('Secteur 1'!$C$31:$DF$35;"Frais de santé"). Mais cela me donne un résultat (10), alors que je sais que je n'ai aucun individu âgé de 18-24 (il s'agit de ma formule test).

En vous remerciant par avance !

Bonne soirée !

Afficher la suite 

Votre réponse

2 réponses

Meilleure réponse
Messages postés
10547
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
26 avril 2019
1393
2
Merci
Bonsoir


NB.SI.ENS('Secteur 1'!$C$3:$DF$3;"18-24") donne 0 et d'ailleurs NB.SI.ENS n'est pas utilse puisque tu ne teste qu'une plage, un NB;SI suffirait
mais NB.SI.ENS('Secteur 1'!$C$31:$DF$35;"Frais de santé"). comptabilise tous les frais de sante !! (et même remarque NB.SI suffit

Si tu veux cumuler le critère âge et le critère frais il fait le faire avec un NB.SI.ENS pour chaque ligne de frais et ajouter l'ensemble
=NB.SI.ENS('Secteur 1'!$C$3:$DF$3;"18-24";'Secteur 1'!$C$31:$DF$31;"Frais de santé") + NB.SI.ENS('Secteur 1'!$C$3:$DF$3;"18-24";'Secteur 1'!$C$32:$DF$32;"Frais de santé") +NB.SI.ENS('Secteur 1'!$C$3:$DF$3;"18-24";'Secteur 1'!$C$33:$DF$33;"Frais de santé") + etc

Cdlmnt
Via

Dire « Merci » 2

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 40220 internautes nous ont dit merci ce mois-ci

Raymond PENTIER
Messages postés
48661
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
26 avril 2019
16149 -
Bonsoir Prune.

Je te recommande de bien étudier la réponse de mon jeune camarade via55.
Tu y trouveras de précieuses indications sur la logique et le mécanisme des fonctions NB.SI et NB.SI.ENS, ainsi que sur l'opportunité de les intégrer à une formule, et sur la définition des plages concernées.
Tout cela te sera très utile pour la suite de tes travaux sur Excel.

Cordialement.
Commenter la réponse de via55
Messages postés
2
Date d'inscription
lundi 8 avril 2019
Statut
Membre
Dernière intervention
9 avril 2019
0
Merci
Merci beaucoup ! Cela me prends plus de temps que prévu, mais avec un peu de patience et de rigueur, la formule fonctionne bien !

Bonne journée ! :)
Commenter la réponse de Prune63000