Menu

Calcul nb d'occurences [Résolu]

- - Dernière réponse :  fafam - 5 avril 2019 à 15:28
Bonjour,
j'ai une liste type de mots contenues dans 1 colonne et je souhaiterais savoir combien de fois ces mots ont été saisis dans une autre colonne (1 mot par cellule dans les 2 cas). Impossible de trouver la formule. SVP, quelqu'un peut-il m'aider ?
Merci


Configuration: Windows / Internet Explorer 11.0
Afficher la suite 

Votre réponse

1 réponse

Meilleure réponse
Messages postés
23870
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 avril 2019
5764
1
Merci
Bonjour
=NB.SI(Colonne à analyser;cell mot)

soit pour une liste de référence débutant en A2 et une liste à analyser en colonne C:

=NB.SI(C:C;A2)

crdlmnt

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 40432 internautes nous ont dit merci ce mois-ci

Désolée mais cela fonctionne uniquement pour le mot contenu en A2. Peut-être me suis-je mal exprimée. Ma colonne à analyser est bien C et ma liste type de mots va de A2 à A10 dans une autre feuille et je ne veux pas additionner les NB.SI parce que cette liste de mots varie souvent (j'ajoute ou je supprime une ou plusieurs lignes avant la dernière ligne)
Vaucluse
Messages postés
23870
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 avril 2019
5764 -
Pas tout compris mais alors un peu au hasard essayez avec une colonne C de 2 à 1000

=SOMMEPROD((NB.SI(C2:C1000;A2:A10))*1)

vu le poids de la formule mieux vaut limiter les adresses au nombre de ligne utile (éviter par exmple C:C)
crdlmnt
Cela fonctionne !! Merci beaucoup
Commenter la réponse de Vaucluse