Menu

Somme cellule contenant texte + nombre (avec conditions) [Résolu]

- - Dernière réponse : Vaucluse
Messages postés
23868
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 avril 2019
- 4 avril 2019 à 15:45
Bonjour,

Je souhaiterai réaliser le calcul présenté dans ce fichier :
https://www.cjoint.com/c/IDemx6giHRN

La formule que je cherche permettrait de :

-additionner des valeurs présentent dans des cellules du type texte + valeur.
Ex : A1 = pomme3; B1=citron2 ; C1=kiwi5 et donc D1 = 3+2+5 = 10

-en rajoutant une condition excluante : si la cellule contient le mot "pomme" alors on ne compte pas le valeur. Ainsi en reprenant l'exemple

A1 = pomme3 (donc pas compté) ; B1 = citron2; C1=kiwi5 --> D1 = 2 + 5 = 7


J'espère que vous pourrez m'aider.

Merci :)
Afficher la suite 

Votre réponse

3 réponses

Messages postés
23868
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 avril 2019
5763
0
Merci
Bonjour
voyez ici, en supposant que les textes de votre exemple représentent bien tout vos cas de figures
sino revenez en précisant un peu plus
https://mon-partage.fr/f/YplhA62i/
crdlmnt
Commenter la réponse de Vaucluse
0
Merci
Merci pour ta réponse,

Malheureusement il y a beaucoup plus de cas de figure que dans mon exemple.

Pour préciser :

-Il y a entre 2 et 9 cellules à combiner (donc 2 à 9 colonnes)
-Ce seront toujours les cellules contenant la chaine de caractères "*compta*" qui seront exclues (donc ca c'est OK il faut juste que je mette les * )
-Il y aura toujours au moins une cellule contenant la chaine de caractères "*compta*" dans la ligne
-Mais parmi les combinaisons possibles, il y a plus de 100 produits / libellés différents pouvant accompagner la cellule "*compta*".

Donc utiliser la fonction subsitute de cette façon serait très laborieux je pense car il faudrait écrire l'ensemble de la centaine d'autres produits :/

Je ne peux malheureusement pas t'envoyer le fichier original car les infos ne sont pas diffusables.

J'espère avoir été suffisamment clair,

Cdt
Commenter la réponse de Anonyme
Messages postés
23868
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 avril 2019
5763
0
Merci
RE
d'où l'importance de tout préciser dans la question
voila une variante qui permet d'éliminer une liste et d'en prendre une autre en compte.
Elle est soumise à condition, voir les infos en noir dans la feuille
bien sur si ces conditions sont respectées, la liste des "in" peut s'allonger jusqu'à 100
mais il faudra quand même répéter la formule associée à une cellule autant de fois qu'il y a de colonne à sommer
Pour éviter les ennuis éventuelles si des cellules sont vides, il est possible de rajouter une condition à chaque item, qui commencerait par exemple par: =SI(OU(A2="";SOMMEPROD((NB.SI(A2;"*"&out&"*"))*1));0;....
https://mon-partage.fr/f/VIfLUXjY/
bien évidemment, si seul le mot comptabilité est à éliminer une seule cellule suffit dans la liste out

On peut faire beaucoup plus simple si il est garanti:
  • que le montant hors comptabilité est toujours précédé d'un blanc
  • qu'il n'y en a pas d'autres dans la cellule
  • que la valeur à sommer est toujours en fin de texte


et donc si on commence en A2:

=SI(OU(A2="";NB.SI(A2;"*comptabilité*"));0;=STXT(A2;TROUVE(" ";A2;1);30)*1+idem pour B2 et+ idem pour C2 etc..

pour aller plus loin sans le fichier, je ne vois pas

crdlmnt
Commenter la réponse de Vaucluse