Menu

Calculer la TVA si... [Résolu]

Messages postés
4
Date d'inscription
mercredi 3 avril 2019
Statut
Membre
Dernière intervention
4 avril 2019
- - Dernière réponse : Chat-Khaal
Messages postés
4
Date d'inscription
mercredi 3 avril 2019
Statut
Membre
Dernière intervention
4 avril 2019
- 4 avril 2019 à 10:11
Bonjour à tous,
J'ai un petit souci à régler et je ne sais pas trop comment faire.

Je suis en train de faire un tableur avec mes prix d'achats, de vente etc mais j'ai deux régimes de TVA à gérer sur la même feuille, certains produits sont soumis à 21% de TVA et pour d'autres produits je dois calculer la TVA sur la marge...

Donc je voudrais que lorsque la cellule A contient le mot "spécial", le régime TVA se calcule sur la marge et si la cellule A contient n'importe quel autre mot que la TVA se calcule normalement.

Pour calculer la TVA sur la marge il faut en fait que le prix d'achat et le prix de vente soit entrés et calculer la TVA sur la différence entre les deux.

Croyez vous que ce soit possible ?

Merci !
Afficher la suite 

Votre réponse

2 réponses

Meilleure réponse
Messages postés
48621
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
21 avril 2019
16108
1
Merci
Bonjour, Vaucluse.

Bonjour, Chat-Khaal.
Ce n'est pas très évident ! Voici les formules.
Dans un premier temps je te les présente spécifiquement pour chaque code.
C'est surtout celles en colonne E qui importent.

La fusion dans une même formule des deux cas de figure donne :
  • en colonne C, la formule =SI(A:A="spécial";F:F;E:E)*0,21
  • en colonne E, la formule =SI(A:A="spécial";(B:B+D:D*0,21);B:B)/1,21

Pas la peine d'applaudir, car j'y ai mis un sacré bout de temps !

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 40516 internautes nous ont dit merci ce mois-ci

Chat-Khaal
Messages postés
4
Date d'inscription
mercredi 3 avril 2019
Statut
Membre
Dernière intervention
4 avril 2019
-
Super, merci beaucoup Raymond pour ton intervention !
En effet ça fonctionne !

J'applaudis quand même à deux mains car ça résout mon problème ! Merci beaucoup !
Commenter la réponse de Raymond PENTIER
Messages postés
23867
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 avril 2019
5763
0
Merci
Bonjour
à adapter çà défaut de connaître vos données
en A2: type TVA spécial ou autre
En B2: prix d'achat
en C2 prix de vente HT

la formule:
=SI(A2="spécial";(C2-B2)*21%;C2*21%)

crdlmnt
Chat-Khaal
Messages postés
4
Date d'inscription
mercredi 3 avril 2019
Statut
Membre
Dernière intervention
4 avril 2019
-
Bonsoir, merci beaucoup pour votre réponse !!!

C'est pas mal mais la réponse s'inscrit à la négative...
En fait voici l'exemple de ce que je veux faire:
A B C D E
Normal 100,00 € 17,36 € 50,00 € 82,64 €
Normal 100,00 € 17,36 € 50,00 € 82,64 €
Expo 100,00 € 17,36 € 50,00 € 82,64 €
Spécial 100,00 € -6,86 € 50,00 € 82,64 €
Normal 100,00 € 17,36 € 50,00 € 82,64 €
Spécial 100,00 € -6,86 € 50,00 € 82,64 €

La colonne A contient le mot déclencheur ou pas, B = Prix de vente TVA comprise (c'est la colonne à remplir manuellement), C= le montant de la TVA (en fonction du mot contenu par A), D= prix d'achat HTVA et E= Prix de vente HTVA.

Avec votre formule actuelle la colonne C se met en négatif quand le mot spécial est mentionné. Je voudrais que le montant de la TVA et le prix de vente hors TVA se calculent tous seuls mais je crois que l'un empeche l'autre de le faire...
Chat-Khaal
Messages postés
4
Date d'inscription
mercredi 3 avril 2019
Statut
Membre
Dernière intervention
4 avril 2019
-
Zut, les colonne se mettent pas comme je l'espérais...
Commenter la réponse de Vaucluse