Menu

Reconnaissance de #N/A [Résolu]

Messages postés
2
Date d'inscription
mercredi 3 avril 2019
Statut
Membre
Dernière intervention
3 avril 2019
- - Dernière réponse : Vaucluse
Messages postés
23867
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 avril 2019
- 3 avril 2019 à 14:31
Bonjour,
J'ai un petit problème avec une formule, j'aimerais avoir quelquechose du style :
=SI(B1=#N/A;1;0)
Sauf que la fonction ne marche pas et ne semble pas reconnaitre la valeur "#N/A"

Des idées sur ce que je pourrais faire pour y remédier ?


Configuration: Windows / Chrome 73.0.3683.86
Afficher la suite 

Votre réponse

1 réponse

Messages postés
23867
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 avril 2019
5763
0
Merci
Bonjour

=SI(ESTERREUR(B1);1;0)

mais vous pouvez aussi éviter le #N/A en B1 (Excel >2007)

=SIERREUR(votre formule);"")

et vous pouvez remplacer ou rajouter entre les guillemets une information quelconque qui s'affichera en cas d'erreur

crdlmnt
VieuxGueux
Messages postés
2
Date d'inscription
mercredi 3 avril 2019
Statut
Membre
Dernière intervention
3 avril 2019
-
Bonjour, ça marche, merci beaucoup !
Ca m'enlève une belle épine du pied
Vaucluse
Messages postés
23867
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 avril 2019
5763 -
Pas de quoi
je passe le sujet en résolu
bonne route
crdlmnt
Commenter la réponse de Vaucluse