Menu

Excel - Formule [Résolu]

Messages postés
35
Date d'inscription
jeudi 21 mars 2019
Statut
Membre
Dernière intervention
6 avril 2019
- - Dernière réponse : Vaucluse
Messages postés
23867
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 avril 2019
- 5 avril 2019 à 12:23
Bonjour j'aimerais s'avoir deux petite choses :)

Tous d'abord je voulais 'avoir si c'était possible d'avoir une formule du style, que quand il y a marquer tel mot, elle fait le calcul, mais si ce mot en question n'est pas marquer rien ne ce passe la case reste vide :

J'ai fait ça comme formule :

=SI(ET(M248="IRU");L248*P248*1000)


Deuxième petite question,

J'aimerais avoir comme formule que quand sur une case (ex: C253) il y a marquer devis, ben que sur la case (D253) il y et marquer 1. mais ca sur plusieurs mots yen a 9.. il y a: Avant vente, Expression de besoin, Signée, Perdu, Actualisé, cloturé et devis-travaux


Mercii d'avance ;)))!!!
Afficher la suite 

Votre réponse

2 réponses

Messages postés
23867
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 avril 2019
5763
0
Merci
Bonjour

1° formule, le ET est inutile

=SI(M248="IRU";L248*P248*1000;"")

2° formule:

=NB.SI(C253;"*devis*")

attention aux signes. Renverra 1 si C253 contient le mot devis dans n'importe quel texte, sino renvoi 0
pour avoir une cellule blanche
=SI(NB.SI(C253;"*devis*");1;"")

crdlmnt

warckfar
Messages postés
35
Date d'inscription
jeudi 21 mars 2019
Statut
Membre
Dernière intervention
6 avril 2019
-
mercii :)
warckfar
Messages postés
35
Date d'inscription
jeudi 21 mars 2019
Statut
Membre
Dernière intervention
6 avril 2019
-
Bonjour du coup avec cette formule comme je fait pour mettre plusieurs condition car j'ai :

1 - Expression de besoin = 1
2 - Avant Vente = 2
3 - Signée = 3
4 - Devis = 4
5 - Actualisé = 5
6 - Perdu = 6
7 - Fin contrat = 7
8 - Cloturé = 8
9 - Devis travaux =9


Je peux faire un formule avec tout ça ou ca va être trop gros ?

Merci d'avance
Vaucluse
Messages postés
23867
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 avril 2019
5763 -
Bonjour
voyez ici si cela peut solutionner votre problème
et revenez si difficultés, mais précisez les quelles elles sont
https://mon-partage.fr/f/TJDedZKN/
crdlmnt
warckfar
Messages postés
35
Date d'inscription
jeudi 21 mars 2019
Statut
Membre
Dernière intervention
6 avril 2019
-
Donc oui ca marche mais je veux que ça copier que 1 ou 2 ou 3 etc sauf que sa me copier "1 - expression de besoin ou 2 - avant vente etc sauf que je veux pas ça..

Exemple:

j'ai en colonnes A 1 L’état (c'est a dire qu'il va y avoir écrit : 1 - expression de besoins, 2 - avant vente etc)
Et en colonne B, j'aimerais avoir en font de ce qu'il a écrit dans la colonne a 1, 2, 3 etc etc

J’espère avoir était clair :) en tout cas merci pour ton fiché !!!
Vaucluse
Messages postés
23867
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 avril 2019
5763 -
Re
pas grand chose à voir avec le question initiale
Pour ressortir le N° avant le tiret dans un texte en A2, si le N° est toujours au début
en B2:
=STXT(A2;1;TROUVE("-";A2)-1)
et pour le numériser car il ressort en format texte:
=STXT(A2;1;TROUVE("-";A2)-1)*1
et si ça ne convient toujours pas, déposez un modèle là où vous avez trouvé mon fichier, en précisant ce que vous attendez et en revenant coller le lien
crdlmnt
Commenter la réponse de Vaucluse
Messages postés
1722
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
19 avril 2019
637
0
Merci
Bonjour,

Concernant votre première formule... le Et n'est pas nécessaire, vous n'avez qu'une seule et unique condition.

Votre formule ressemble plus à :
- Si(M248="IRU";L248*P248*1000;0)

Cette formule c'est si la case ne contient QUE IRU, si elle doit contenir IRU ( avec des mots autour) la formule devient plutôt :
- Si(NB.SI(M248="*IRU*")=1;L248*P248*1000;0)

Votre deuxième question, je vous conseil de passer par un tableau intermédiaire constitué de 2 colonne:
- La première => les mots possible
- La deuxième => Le nombre à sortir.

Et d'utiliser une formule rechercheV :)
warckfar
Messages postés
35
Date d'inscription
jeudi 21 mars 2019
Statut
Membre
Dernière intervention
6 avril 2019
-
mercii
Commenter la réponse de diablo13800