Menu

Date du mois précédent à fin de mois [Résolu]

- - Dernière réponse :  sev33130 - 2 avril 2019 à 10:05
Bonjour,


J'aimerais savoir s'il est possible, sous Excel Mac, de créer une date qui me donnerait la date à la fin du mois tout en sachant que cette formule doit me permettre d'avoir une date en fonction de la date à laquelle je vais saisir mon document.

Je m'explique : si nous sommes le 1er avril 2019 et que j'envoie un document dont les éléments repris dedans sont du mois précédent, cette date doit être à fin mars.

En revanche, si je tape mon document le 25 mars pour des éléments toujours de mars, ma date sera toujours à fin mars.

Je ne trouve pas comment faire : toujours étais nulle

Merci de votre aide.
Afficher la suite 

1 réponse

Messages postés
24194
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 juillet 2019
4677
0
Merci
Bonjour

si vos dates à transmettre sont en A2:A100,cette formule:

=SI(SOMMEPROD((MOIS(A2:A100)=MOIS(AUJOURDHUI())-1)*1);FIN.MOIS(AUJOURDHUI();-1);FIN.MOIS(AUJOURDHUI();0))

crdlmnt


Vaucluse
Messages postés
24194
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 juillet 2019
4677 -
... et en complément vous pouvez automatiser le texte en B124 avec cette formule:
="Nous vous prions de bien vouloir trouver, ci-joint, en 2 exemplaires, les situations de travaux à fin "&MAJUSCULE(TEXTE(D16;"mmmm"))&" "&ANNEE(D16)
mais ça ne fonctionne pas. Cela reste affiché comme suit :
="Nous vous prions de bien vouloir trouver, ci-jont, en 2 exemplaires, les situations de travaux à fin "&MAJUSCULE(TEXTE(D16;"mmmm"))&" "&ANNEE(D16) de :
Vaucluse
Messages postés
24194
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 juillet 2019
4677 -
Probablement un mauvais copier/coller
voyez ici:
https://mon-partage.fr/f/oDWz9rWx/
Bonjour,

Bon et bien j'ai beau essayé, rien de fonctionne.

Tans pis ! Je laisse tomber.

Merci quand même. Bonne journée.
Commenter la réponse de Vaucluse