Menu

Formule Excel trop longue => Erreur [Résolu]

Messages postés
2
Date d'inscription
jeudi 28 mars 2019
Statut
Membre
Dernière intervention
28 mars 2019
- - Dernière réponse : Doncoco6141
Messages postés
2
Date d'inscription
jeudi 28 mars 2019
Statut
Membre
Dernière intervention
28 mars 2019
- 28 mars 2019 à 18:05
Bonjour,
J'ai créé une formule contenant beaucoup de condition "SI", avec des arguments faisant rapport à des cellules venant d'une autre feuille (dans le même classeur évidement).
La formule est très longue et me retourne l'erreur :"Valeur".

J'ai essayé de prendre chaque condition séparément et là tout fonctionne, mais une fois imbriquées ensembles, excel ne veut plus rien savoir.

Vue d'ensemble de la formule :

=SI(M5="";"";SI(J5=1;SI(AM5=1;'Temps par travail'!$C$31;SI(AN5=1;'Temps par travail'!$D$31;SI(AO5=1;'Temps par travail'!$E$31;SI(AP5=1;'Temps par travail'!$F$31;SI(AQ5=1;'Temps par travail'!$G$31;SI(AR5=1;'Temps par travail'!$H$31;SI(AS5=1;'Temps par travail'!$I$31)))))));SI(J5=2;SI(AM5=1;'Temps par travail'!$C$65;SI(AN5=1;'Temps par travail'!$D$65;SI(AO5=1;'Temps par travail'!$E$65;SI(AP5=1;'Temps par travail'!$F$65;SI(AQ5=1;'Temps par travail'!$G$65;SI(AR5=1;'Temps par travail'!$H$65;SI(AS5=1;'Temps par travail'!$I$65))))))))));SI(J5=3;SI(AM5=1;'Temps par travail'!$C$99;SI(AN5=1;'Temps par travail'!$D$99;SI(AO5=1;'Temps par travail'!$E$99;SI(AP5=1;'Temps par travail'!$F$99;SI(AQ5=1;'Temps par travail'!$G$99;SI(AR5=1;'Temps par travail'!$H$99;SI(AS5=1;'Temps par travail'!$I$99))))))))


Si quelqu'un pouvait me donner un conseil pour m'en sortir j'en serais vraiment très reconnaissant.
D'avance merci


Configuration: Windows / Chrome 73.0.3683.86
Afficher la suite 

Votre réponse

1 réponse

Messages postés
23977
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 mai 2019
4596
0
Merci
Bonjour
j'ai copié collé votre formule dans un modèle avec une feuille nommée et effectivement, elle renvoie bien valeur;
Sauf erreur, vos parenthèses sont pal placées, et si je corrige, la formule me renvoie bien une cellule blanche. C'est à dire:
7 parenthèses derrière chaque groupe de valeur de J et trois de plus (soit 10 donc, à la fin)
Mais je ne garantis pas!
crdlmnt

Doncoco6141
Messages postés
2
Date d'inscription
jeudi 28 mars 2019
Statut
Membre
Dernière intervention
28 mars 2019
-
Merci beaucoup,
Je n'étais pas loin de la solution en fait.
Bonne soirée ;)

Sujet résolu
Commenter la réponse de Vaucluse