Remplacement générique chaîne de caractère [Résolu]

- - Dernière réponse :  SSamoloss - 26 mars 2019 à 10:44
Bonjour à tous,

J'ai un fichier excel avec une colonne constituée de groupement de texte type :

commentcamarche
commentcamarche
commentcamarchepas
commentcamarchepas
commentuvas
commentuvaspas
commentuvaspas

J'aimerai pouvoir remplacer le premier groupement "commentcamarche" par "groupement1, le deuxième "commentcamarchepas" par "groupement2" et ainsi de suite.

Merci de votre aide,




Configuration: Windows / Chrome 74.0.3706.0
Afficher la suite 

2 réponses

Messages postés
2440
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
2 août 2019
268
0
Merci
Bonjour,

Un essai a méthode manuelle !

https://www.cjoint.com/c/ICzsnJ4cbAU

Vu qu'on ne sait pas a quoi ça sert et quel en est le contexte !!!


Crdlmt
Bonjour,

Merci pour ton retour rapide. J'y suis presque sauf que les groupements de texte ne sont pas toujours constitués de deux mots. En fait c'est complètement aléatoire.

Du coup je peux rencontrer dans mon fichier :

commentcamarche
commentcamarche
commentcamarche
commentcamarche
commentcamarchepas
commentcamarchepas
commentuvas
commentuvaspas
commentuvaspas
commentuvaspas


J'espère que c'est assez clair.

Merci,
Commenter la réponse de DjiDji59430
Messages postés
22795
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
3 août 2019
5570
0
Merci
Bonjour à tous,

A tout hasard, avec ta liste qui démarre en A2, dans B2 :
=SI(EQUIV(A2;A:A;0)=LIGNE();MAX($B$1:B1)+1;INDEX(B:B;EQUIV(A2;A:A;0)))


ou si tu ne veux numéroter que la 1ère apparition :
=SI(EQUIV(A2;A:A;0)=LIGNE();MAX($B$1:B1)+1;"")

eric

En essayant continuellement, on finit par réussir. 
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
Bonjour Eric,

Merci c'est exactement ce que je cherchais !

Merci et bonne journée !
Commenter la réponse de eriiic