Menu

Calcul d'une somme a partir d'une variable,d'une date dans une case

- - Dernière réponse : PHILOU10120
Messages postés
5327
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
17 juin 2019
- 26 mars 2019 à 09:28
Bonjour,
j'aimerai savoir s'il est possible de réaliser ma demande suivante:

Présentation du tableau:
Colonne A: Nom
Colonne B: Date
Colonne C: Produits
Colonne D: QTE
Colonne E: Prix unitaire
Colonne F: total (D*E)
Colonne G: total de la commande

Dans la colonne G, j'aimerai afficher le total de la Commande de client1 (je n'ai pas de base de donnée, je connais le nom du client que lorsqu'il me passe une commande) à la date du 01/01/2019 pour les produits:
Pantalon QTE 2 prix unitaire 40€ (Total en colonne F à 80 €)
Chemise QTE 1 prix unitaire 30€ (Total en colonne F à 30 €)
Chaussette QTE 3 prix unitaire 4€ (Total en colonne F à 12 €)
Donc on va dire C2=pantalon,C3=chemise et C4=chaussette , et si possible que le total de la commande ne s'affiche que en G2 ( que G3,G4 reste vide, mais si en A5 j'ai client2, il me recommence la formule automatiquement pour mettre un total à G5)
Afficher la suite 

1 réponse

Meilleure réponse
Messages postés
5327
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
17 juin 2019
317
1
Merci
Bonjour

Essayer cette formule en G2

=SI(ET(A2=A1;B2=B1);"";SOMME.SI.ENS($F$2:$F$200;$A$2:$A$200;A2;$B$2:$B$200;B2))

à tirer vers le bas

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 43345 internautes nous ont dit merci ce mois-ci

Commenter la réponse de PHILOU10120