Menu

Fonctions imbriquées SI, OU, ET, ESTNA [Résolu]

- - Dernière réponse : Vaucluse
Messages postés
23976
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 mai 2019
- 22 mars 2019 à 14:13
Bonjour,
Je bataille depuis plusieurs jours et n'y arrive pas !! Je suis sous Excel 365.
Voici ma problématique et ce que je voudrais écrire dans une seule et même cellule:
Condition 1: Si Q2=0, alors 0
Condition 2: Si AF2= "nodata" ou ESTNA, alors vide
Condition 3: sinon 1

Merci de votre aide !!

Configuration: Windows / Chrome 72.0.3626.121
Afficher la suite 

Votre réponse

3 réponses

Messages postés
23976
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 mai 2019
4595
0
Merci
Bonjour
=SI(Q2=0;0;SI(OU(ESTNA(AF2);AF2="nodata");"";1))

inverser l'ordre des conditions selon ce que vous voulez comme prioritaire entre Q2 et AF2

crdlmnt

Merci, ça part bien. J'ai rajouté une parenthése à la fin pour fermer les conditions. Par contre, pour els "no data" et ESTNA, il me rapporte 1 ?!? Une idéé??
Vaucluse
Messages postés
23976
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 mai 2019
4595 -
qu'avez vous dans cette cellule AF2? Si c'est un renvoi #N/A par formule, mieux vaudrait peut être l'éviter, c'est assez simple à partir de Excel 2013
dites nous
sinon essayez de dissocier les deux conditions, le #N/A perturbe un peu tout:
=SI(Q2=0;0;SI(ESTNA(AF2);"";SI(AF2="nodata");"";1)))

mas n'oubliez pas que dans tous les cas Q2 est prioritaire
Commenter la réponse de Vaucluse
0
Merci
Je viens de tilter que dans ma cellule AF2, j'ai un RECHERCHEV d'un autre tableau, et je pense que le pb vient de là, correct? C'est solutionnable?
Vaucluse
Messages postés
23976
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 mai 2019
4595 -
Re
si la cellule AF2 renvoie #N/A c'est qu'elle cherche une valeur inexistante
alors deux options, si votre Excel >= 2013 dans cette cellule:

=SIERREUR(votre formule complète);"")

qui laissera une cellule "blanche" et donc permettra d'associer dans votre autre formule:

=SI(Q2=0;0;SI(OU(AF2="";AF2="nodata");"";1))

ou alors en AF2 terminer la formule comme suit:

=SIERREUR(votre formule complète);"nodata")

l'autre formule deviendra:

=SI(Q2=0;0;SI(AF2="nodata";"";1)

crdlmnt
Commenter la réponse de Cath
0
Merci
Résolu !!!! Merci merci merci !!!
Vaucluse
Messages postés
23976
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 mai 2019
4595 -
Pa de quoi
je passe le sujet en résolu
Bonne route
crdlmnt
Commenter la réponse de Cath