Calculer des temps de travail via une extraction de badgeages [Résolu]

- - Dernière réponse :  Adeleh29 - 19 mars 2019 à 13:05
Bonjour,

Je suis face à un problème et ai commencé à me lancer dans des formules à tiroirs et rallonge mais je pense qu'il est possible de faire plus simple, j'espère que vous pourrez m'aider !

Voici la situation :

Je cherche à calculer la répartition en horaires de jour / nuit / dimanche et jours fériés à partir de badgeages
Ces badgeages peuvent être simple ( une entrée / une sortie) ou double (une entrée / une sortie / une entrée / une sortie)

Je dispose :

- d'une extraction des badgeages au format
A1 : Date 1 / B1 : heure entrée / C1 : minutes entrée / D1 : secondes entrée
A2 : Date 1 / B2 : heure sortie / C2 : minutes sortie / D2 : secondes sortie
Il peut ainsi y avoir 2 ou 4 lignes par jour

- d'une formule fonctionnant dans le cadre d'un badgeage simple
Soit A15 : date / B15 : heure entrée / C15 : heure sortie

Jour : = SI(C15="";"";SI(OU(JOURSEM(A15)=1;SI(NON(ESTVIDE(B15));MOD(D15-C15;1);0)); 0;(MOD(D15-C15;1)-G15)))

Dimanches et jours fériés : =SI(C15="";"";SI(OU(JOURSEM(A15)=1;SI(NON(ESTVIDE(B15));MOD(D15-C15;1);0)); MOD(D15-C15;1)-G15;0))

NUIT : =SI(OU(C15="";D15="");"";(MOD(D15-C15;1)-SI(D15>C15;MAX(0;MIN(D15;22/24)-MAX(C15;7/24));MAX(0;22/24-MAX(C15;7/24))+MAX(0;MIN(D15;22/24)-7/24))))

J'aurais besoin :
- de formaliser mon extraction de badgeages pour l'avoir au format
A1 : date / B1 : heure entrée 1 / C1 : heure sortie 1 / D1 : heure entrée 2 ou néant / E1 : heure sortie 2 ou néant
- de compléter mes formules afin qu'elles prennent en compte la possibilité de badgeages doubles
- et idéalement de dédoubler la répartition nuit avec une catégorie nuit de 00h à 22h et une catégorie nuit de 22h à 7h

Une idée ? Ça m'aiderait beaaaaucoup ! Merci d'avance à ceux qui répondont à ce post !

Configuration: Windows / Firefox 52.0
Afficher la suite 

3 réponses

Meilleure réponse
Messages postés
1914
Date d'inscription
lundi 3 mai 2010
Statut
Membre
Dernière intervention
7 août 2019
120
1
Merci
Bonjour,

1/ tu voulais écrire "jour de 7h à 22h" ?
2/ avec le travail de nuit, la date de sortie peut être différente de la date d'entrée.
3/ peux-tu fournir un fichier anonymisé et les règles de priorité : dimanche de 0h à 7h est comptabilisé comme nuit ou dimanche ?

A+

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 58822 internautes nous ont dit merci ce mois-ci

Hello,

Effectivement ce n'était pas clair, il y a 4 catégories :
- Jour de 7h à 22h
- Nuit de 22h à 00h
- Nuit de 00h à 7h
- Dimanches et jours fériés

Les horaires de nuit sont toujours comptabilisées comme telles même les dimanches et jours fériés.

Dans le cas d'une date de sortie différente de la date d'entrée, une sortie est effectuée automatiquement (du logiciel dont j'extrais les badgeages) à 23h59 et une entrée le lendemain à 00h.
Cela me fait qu'il pourrait, du coup, y a voir potentiellement 3 entrées et sorties sur un jour mais dans la réalité cela n'arrive pas.

Voici le tableau avec 3 feuilles :
- les éléments
- format attendu
- tentatives

https://www.cjoint.com/c/ICsphmzaRZZ

MERCI !!!
Zoul67
Messages postés
1914
Date d'inscription
lundi 3 mai 2010
Statut
Membre
Dernière intervention
7 août 2019
120 -
Re,

Base-toi là-dessus peut-être.
https://www.cjoint.com/c/ICsrm00rY2c

A+
Commenter la réponse de Zoul67
Messages postés
22841
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
20 août 2019
5595
1
Merci
Bonjour à tous,

une bonne partie de faite : mise en forme des heures entrées/sorties pour que ce soit exploitable.
il reste le calcul des jours/nuits etc. Mais ça c'est ch... et comme je vois que tu manipules bien je te laisse ce plaisir ;-)
https://www.cjoint.com/c/ICswTyHkVO6
eric

En essayant continuellement, on finit par réussir. 
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 58822 internautes nous ont dit merci ce mois-ci

Commenter la réponse de eriiic
0
Merci
Hello à tous les deux,

MERCI pour vos réponses !

Ça fonctionne très bien et en compilant vos deux propositions, mon tableau est au top.

Bonne journée :)
Commenter la réponse de Adeleh29