Menu

Formule si imbriquée

Messages postés
3
Date d'inscription
samedi 16 mars 2019
Dernière intervention
16 mars 2019
-
bonjour,

je suis en train de créer une formule avec plusieurs conditions mais je bloque.
j’ai essayé toutes les conditions seules et elles fonctionnent bien , mais pour les assembler je bloque totalement, je ne sais pas si je m'y prends bien.

merci de votre aide

ci dessous ma formule :
=SI(B2>D2;SI(B2>F2;“a”;SI(D2>B2;SI(D2>F2;“s”;SI(F2>D2;SI(F2>B2;“l”;SI(B2<>0;SI(B2=D2;SI(D2=F2;“asl”;SI(B2=D2;SI(F2<B2;“as”;SI(B2=F2;SI(D2<B2;“al”;SI(D2=F2;SI(B2<D2;“sl”;SI(B2=0;SI(B2=D2;SI(D2=F2;“personne”))))))))))))))))))

Afficher la suite 

Votre réponse

1 réponse

Messages postés
243
Date d'inscription
samedi 2 février 2019
Dernière intervention
22 mars 2019
22
0
Merci
Bonjour,
Tu essayes de faire tourner une formule de comparaisons avec D2 mais il n'y a rien en D2 !
Yoyo01000
Messages postés
243
Date d'inscription
samedi 2 février 2019
Dernière intervention
22 mars 2019
22 -
Ça ne peut fonctionner car tout tes SI n'ont pas de renvois de valeurs si vrai ou faux.
Par exemple =SI(B2>D2 ne renvoie rien puisque tu continues avec &SI.
Yoyo01000
Messages postés
243
Date d'inscription
samedi 2 février 2019
Dernière intervention
22 mars 2019
22 -
Tu peux coller tes bouts entre eux ainsi :
=SI(B2>D2;"ton résultat désiré" ;"")&SI(....)
Yoyo01000
Messages postés
243
Date d'inscription
samedi 2 février 2019
Dernière intervention
22 mars 2019
22 -
Et encore mieux, en figeant tes cellules pour tirer les formules vers le bas :
=SI($B$2>$D$2;"ton résultat désiré" ;"")&SI(....)
erika1112
Messages postés
3
Date d'inscription
samedi 16 mars 2019
Dernière intervention
16 mars 2019
-
merci, j'ai imbriqué si et et , ça à l'air de fonctionner.

=SI(ET(B2>D2;B2>F2);"a";SI(ET(D2>B2;D2>F2);"s";SI(ET(F2>B2;F2>D2);"l";SI(ET(B2<>0;B2=D2;D2=F2);"asl";SI(ET(B2=D2;F2<B2);"as";SI(ET(B2=F2;D2<B2);"al";SI(ET(D2=F2;B2<D2);"sl";SI(ET(B2=0;B2=D2;B2=F2);"personne"))))))))


bon weekend
Yoyo01000
Messages postés
243
Date d'inscription
samedi 2 février 2019
Dernière intervention
22 mars 2019
22 -
Parfait alors !
Si cela fonctionne comme tu le souhaites, tu peux passer le sujet en [Résolu]
Commenter la réponse de Yoyo01000