Menu

Formule pour compter combien de fois se trouve une même valeur dans une colonne

Messages postés
1
Date d'inscription
jeudi 14 mars 2019
Dernière intervention
14 mars 2019
- - Dernière réponse : PapyLuc51
Messages postés
1860
Date d'inscription
dimanche 3 mai 2009
Dernière intervention
24 mars 2019
- 14 mars 2019 à 12:33
Bonjour
J'ai une liste de 186 000 références clients dans la colonne A , et je souhaite voir apparaître dans la colonne B le nombre de fois qu'existe cette même référence client dans la colonne A.
J'ai tenté de mettre en avant les doublons par la mise en forme conditionnelle mais cela plante ( fichier trop lourd)
J'ai tenté le tableau croisé dynamique mais je ne peux filtrer et étonnamment je ne retrouve que le chiffre 1 face à la référence client.
Or si je fais une suppression des doublons il m'indique supprimé 79 lignes. ( j'ai besoin de visualiser le codes clients en doublons)
J'ai tenté le nb.si(A:A; ET LA EST MON PB je n'ai pas de critère à saisir).
Il doit exister une autre formule ou bien???
Merci pour votre aide
Afficher la suite 

Votre réponse

2 réponses

Messages postés
251
Date d'inscription
samedi 2 février 2019
Dernière intervention
25 mars 2019
22
0
Merci
Bonjour,
la formule =NB.SI(A:A;"valeur cherchée";"") ne peut fonctionner si tu as beaucoup de critères différents dans ta colonne A.
Commenter la réponse de Yoyo01000
Messages postés
1860
Date d'inscription
dimanche 3 mai 2009
Dernière intervention
24 mars 2019
454
0
Merci
Bonjour

Voilà comme je vois la chose :
Faire une copie de la la zone A2:A186000 ; la coller B2 et supprimer les doublons sur cette colonne

En C2 =NB.SI($A$2:$A$186000;B2) et incrémenter jusqu'à hauteur de la dernière cellule renseignée de la colonne B

Cordialement
Commenter la réponse de PapyLuc51