Menu

Souci de formule

- - Dernière réponse : Yoyo01000
Messages postés
251
Date d'inscription
samedi 2 février 2019
Dernière intervention
25 mars 2019
- 13 mars 2019 à 21:46
Bonjour,
je suis bloquer sur une formule.
si dans une colonne (exemple colonne A) je trouve le texte "X="( exemple ligne 5 (A5) , je voudrai que sur la case a coter B5 pour l'exemple , oui il se trouvera une valeur je lui additionne une valeur qui se trouve en C20 (C20 étant une valeur que je pourrai modifier a ma guise)


Configuration: Windows / Chrome 72.0.3626.121
Afficher la suite 

Votre réponse

6 réponses

Messages postés
519
Date d'inscription
lundi 2 juillet 2018
Dernière intervention
26 mars 2019
51
0
Merci
Bonjour

A mettre en B5 si j'ai bien compris
=SI(A1="x";C20;"")
Cordialement
Commenter la réponse de JCB40
0
Merci
Non c’est pas exactement ça si dans la colone À je trouve X dans la case à coter il existe une valeur exemple 10 et que dans une case exemple c20 j’écris 20 donc en face de « x » je veux retrouver 30
Si « A2 = “X” B2 normalement est égale à 10 mais vu que en C20 =20 je veux retrouver 30 en B2
Commenter la réponse de Ayarifranck
Messages postés
15761
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
26 mars 2019
3637
0
Merci
Bonjour Frank, JCB40

Frank

tu veux dire que
si par exemple, On a 10 en B5, 5 en C20 et X en A5 alors B5 prend la valeur 15 (10+5) ?

Si oui il faut employer une macro en nous disant si on ne travaille que sur la ligne 5 ou une plusieurs lignes; si oui lesquelles
Je vais travailler sur une seul ligne mais parcontre sur dés colonne complète
« X=«  sera toujours dans la colonne À et sa valeur en B et pour la valeur à additionner peux importe
Commenter la réponse de michel_m
0
Merci
C’est ça mais sur dés colonne
Yoyo01000
Messages postés
251
Date d'inscription
samedi 2 février 2019
Dernière intervention
25 mars 2019
22 -
la valeur que tu veux additionner en C20 est toujours en C20 ou alors C20-C21-C22, ... ?
Elle sera toujours dans la même case
Yoyo01000
Messages postés
251
Date d'inscription
samedi 2 février 2019
Dernière intervention
25 mars 2019
22 -
Où as-tu mis ma formule ?
En a1 puis en b1 et aussi dans une case au hasard
Yoyo01000
Messages postés
251
Date d'inscription
samedi 2 février 2019
Dernière intervention
25 mars 2019
22 -
à quelles cellules commencent tes données en colonnes A et B ?
Commenter la réponse de Ayarifranck
Messages postés
251
Date d'inscription
samedi 2 février 2019
Dernière intervention
25 mars 2019
22
0
Merci
Pourquoi -1 merci ?!

Commenter la réponse de Yoyo01000
Messages postés
251
Date d'inscription
samedi 2 février 2019
Dernière intervention
25 mars 2019
22
-1
Merci
Bonjour,
pour être sûr d'avoir bien compris :
tu veux additionner la cellule en B (B5 par exemple) avec la cellule en C (C20 par exemple) si dans la cellule en A (A5 par exemple) se trouve le texte X= ?
dans ce cas :

=SI($A5="X=";SOMME($B5;$C$20);"")

Yoyo01000
Messages postés
251
Date d'inscription
samedi 2 février 2019
Dernière intervention
25 mars 2019
22 -
Et pour info, tu ne peux inscrire une valeur et une formule dans la même cellule. L'une ou l'autre sera systématiquement écrasée, soit par la valeur, soit par la formule.
Yoyo01000
Messages postés
251
Date d'inscription
samedi 2 février 2019
Dernière intervention
25 mars 2019
22 -
Merci de transmettre ton fichier via
mon-partage.fr
Commenter la réponse de Yoyo01000