Menu

Formule SI imbriquée pour date et montant

Messages postés
6
Date d'inscription
mercredi 1 avril 2015
Dernière intervention
11 mars 2019
-
Bonjour,

J'ai essayé à plusieurs reprises une formule avec des SI imbriquée mais cela ne semble pas convenir pour le genre de formule que je souhaite faire. En effet la formule me dit que j'ai trop de données à calculer du coup elle ne fonctionne pas.

Je souhaite mettre en place une formule pour des contrats de sous-traitance par rapport à un montant de facture.

Mon exemple est le suivant :

- Si la date de facture est égale au 28/02 et que le montant est supérieur ou égal à 100 €, alors la date c'est 28/02 - 9 jours, Si la date de facture est égale au 28/02 et que le montant est supérieur ou égal à 300 €, alors la date c'est 28/02 - 10 jours, Si la date de facture est égale au 28/02 et que le montant est supérieur ou égal à 500 €, alors la date c'est 28/02 - 15 jours (les montants suivants sont 700, 900, 1000, 2000, 3000, 4000, 5000).

Je pense me tromper de formule, mais même avec une recherchev, je ne sais pas comment ou quelle formule adopter.

Je vous remercie d'avance pour vos réponses.

Bien cordialement.
Afficher la suite 

Votre réponse

1 réponse

Messages postés
10386
Date d'inscription
mercredi 16 janvier 2013
Dernière intervention
18 mars 2019
1368
0
Merci
Bonjour

Tu peux parfaitement imbriquer des SI

Ex avec montant en C3 et date en D3
=SI(D3<>DATE(2019;2;28);"";SI(C3<=100;D3-9;SI(C3<=300;D3-10;SI(C3<=500;D3-15;SI(C3<=700;D3-20;SI(C3<=900;D3-25;SI(C3<=1000;D3-30;SI(C3<=2000;D3-40;SI(C3<=3000;D3-50;SI(C3<=4000;D3-60;SI(C3<=5000;D3-70;"")))))))))))
A partir de 700 j'ai mis des chiffres bidons puisque tu ne les indiquais pas

Cdlmnt
Via
estre06
Messages postés
6
Date d'inscription
mercredi 1 avril 2015
Dernière intervention
11 mars 2019
-
Bonjour et merci de votre réponse, j'ai fait cette formule et cela me marque :
estre06
Messages postés
6
Date d'inscription
mercredi 1 avril 2015
Dernière intervention
11 mars 2019
-
pour cette formule :
estre06
Messages postés
6
Date d'inscription
mercredi 1 avril 2015
Dernière intervention
11 mars 2019
-
j'ai transformé mon fichier en xslx, effectivement la formule ne met plus d'erreur, mais elle ne fonctionne pas lorsque le montant change elle reste bloquée sur une date
estre06
Messages postés
6
Date d'inscription
mercredi 1 avril 2015
Dernière intervention
11 mars 2019
-
Bon j'ai réussi je pense je vous dirais ça au plus vite. Merci beaucoup de votre aide.
Cordialement.
Commenter la réponse de via55