Menu

Recheche de formule excel

Messages postés
3
Date d'inscription
lundi 11 mars 2019
Dernière intervention
12 mars 2019
- - Dernière réponse : via55
Messages postés
10398
Date d'inscription
mercredi 16 janvier 2013
Dernière intervention
23 mars 2019
- 12 mars 2019 à 18:15
Bonjour, je vous prie de m'aider.
Je dispose de deux colonne excel
Colonne 1 contient: Immatriculation de véhicule 11KN8451/11GK0121
Colonne 2 contient: Immatriculation de véhicule 11KN8451BF/14GU1210

je veux écrire un programme de sorte que s'il un élément de la colonne 2 est identique à un élément de la colle 1; il puisse me mettre "1" si non "0".
Dans l'exemple 11KN8451=11KN8451BF

En fait les immatriculations sot séparées par des "/"
Afficher la suite 

Votre réponse

3 réponses

Messages postés
7687
Date d'inscription
dimanche 13 juin 2010
Dernière intervention
23 mars 2019
1667
0
Merci
Bonjour,

« En fait les immatriculations sot séparées par des "/" »
C'est une très mauvaise méthode, Excel est conçu pour traiter une seule information par cellule.
Commenter la réponse de Patrice33740
Messages postés
10398
Date d'inscription
mercredi 16 janvier 2013
Dernière intervention
23 mars 2019
1369
0
Merci
Bonjour

Une possibilité
En supposant la 1ere imma en A2 et la 2nde en B2, en C2 la formule :
=SI(NB.SI(B2;"*" &GAUCHE(A2;TROUVE("/";A2)-1)&"*")+NB.SI(B2;"*" &DROITE(A2;NBCAR(A2)-TROUVE("/";A2))&"*")>0;1;0)

Cdlmnt
Via
Franck_CI
Messages postés
3
Date d'inscription
lundi 11 mars 2019
Dernière intervention
12 mars 2019
-
Merci cher ami, je vais exploiter votre chemin. Pour l'instant, je trouve les mêmes réponses ques les infos soient les mêmes ou différentes.
Exemple ci-apres
IMMATRICULATION A IMMATRICULATION B Resultat
334HT04/4074CY01 1

BE 5962MD/BE0579MD BE5962MD/BE0579MD 1
Franck_CI
Messages postés
3
Date d'inscription
lundi 11 mars 2019
Dernière intervention
12 mars 2019
-
Merci cher ami, je vais exploiter votre chemin. Pour l'instant, je trouve les mêmes réponses que les infos soient les mêmes ou différentes.
Exemple ci-apres

IMMATRICULATION A: 334HT04/4074CY01

IMMATRICULATION B : .......
Resultat: 1

IMMATRICULATION A: BE 5962MD/BE0579MD
IMMATRICULATION B: BE5962MD/BE0579MD
Résultat: 1
Commenter la réponse de via55
Messages postés
10398
Date d'inscription
mercredi 16 janvier 2013
Dernière intervention
23 mars 2019
1369
0
Merci
S'il y a des espaces indésirables qui empêchent la comparaison il faut d’abord les supprimer dans les colonnes C et D
J'ai modifié la formule pour qu'elle fasse apparaitre le nombre d'immat identiques sur la même ligne soit 2, 1 ou 2
https://mon-partage.fr/f/gQokPVvm/

Cdlmnt
Via
Commenter la réponse de via55