Menu

Supertuxkart version 8.1 ou 8.2 [abandon pour la 8.0] [Résolu]

-
Bonjour,

PC de 2010, la dernière version de ce jeux qui fonctionnait à merveille chez moi est la 8.2

J'ai eu la mauvaise idée de mettre à jour.

Impossible de revenir en arrière, et le jeu ne fonctionne plus comme avant (saccade, moche car obligé de désactiver tous les effets, etc...) because opengl MESA encore à 2.1.

Pas de carte graphique, j'utilise la puce intel intégrée au proco (intel core i5 650) Quelqu'un aurait -il la version espérée de disponible (soit installable, soit juste dézippable, c'est ma préférée) car impossible jusque là de trouver ça sur le net, juste trouvé une version 8.1 chez SourceForge impossible à installer.

Merci, d'avance.

EDIT : bon pas la peine, j'ai repris la 8.0, un peu de régression par rapport à 8.2 mais au moins ça fondctionne.



Configuration: Linux / Firefox 65.0
Afficher la suite 

Votre réponse

4 réponses

Messages postés
28764
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
21 mars 2019
7999
0
Merci
Bonjour,

J'ai l'impression que ta debian date un peu, en debian stable (actuellement stretch) et testing (actuellement buster), actuellement supertuxkart est bien plus avancé :
https://packages.debian.org/fr/buster/supertuxkart

Idem pour
libglu1-mesa
:
https://packages.debian.org/fr/buster/libglu1-mesa

Il est peut être temps de mettre à jour ? ;-)

Bonne chance
Commenter la réponse de mamiemando
0
Merci
Merci de ta réponse mais non, ma Debian bien à jour, et j'avais eu la mauvaise idée de mettre STK vers 9.3

J'avais oublié que mon matos lui est trop vieux et que la puce graphique de mon processeur ne supporte pas plus que 2.1 OpenGl

Et mesa en tient compte !

Je n'ai pas trouvé une 8.2 installable (l'installateur hurle à la non conformité)
Tant pis, la version 8 sans installation fonctionne à merveille, j'aime autant moins de courses qui fonctionnent que plus de courses qui saccadent et sont très moches avec tous les effets visuels désactivés.
mamiemando
Messages postés
28764
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
21 mars 2019
7999 -
Hello,

Merci de ta réponse mais non, ma Debian bien à jour, et j'avais eu la mauvaise idée de mettre STK vers 9.3

Sans doute pour une debian jessie, mais c'est une ancienne version de Debian. Comme le montre les liens de mon message précédents, les paquets que tu évoques ont beaucoup évolués. Je te suggérais donc de migrer vers une version plus récente de debian (e.g. debian buster).

On peut raisonnablement espérer que les version actuelles de supertuxkart sont redevenues belles et fluides :-)

Bonne chance
Commenter la réponse de MAH
0
Merci
Je vais arrêter là après ça, et j'espère que tu auras compris de quoi je parle :
J'ai une Debian Stretch, à jour.

STK 9.3 demande pour fonctionner correctement une version OpenGL minimum 3.1

Or la version OpenGL possible sur un poste est directement et en premier lieu, physiquement déterminée par les caractéristiques de la puce graphique intégrée au proco (dans le cas d'Intel du moins, les autres je ne sais pas)

Or mon Intel Core i5 est un double-cœur (2 coeurs, 4 threads) de première génération (plus de 10 ans) qui ne prend en charge qu'OpenGL 2.1 tout comme mesa de toute façon.

Je n'ai pas de carte graphique supplémentaire et n'en aurai pas l'usage, je ne suis pas accro à STK à ce point là.

Donc Tux en version 8, et sans install en plus, ce qui est pratique, nous suffit largement à mon ordi et à moi.

Compris ?
mamiemando
Messages postés
28764
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
21 mars 2019
7999 -
J'ai très bien compris, et j'espère que de ton côté, tu as compris que je ne faisais que te suggérer une solution.

Si tu es arrivé à résoudre ton problème, tant mieux, c'est le plus important.

Mes suggestions sont simplement une conséquence des numéros de versions que tu as indiqué. En stretch par exemple, supertuxkart est en 0.9.2
https://packages.debian.org/fr/stretch/supertuxkart

Il y a donc peu de rapport avec les versions "8.1 ou 8.2" que tu évoques. J'ai supposé que tu voulais dire 0.8.1 ou 0.8.2, auquel cas, même pour une stretch, le numéro de version semble daté (d'où mon : il faudrait peut-être faire une mise à jour !).

Enfin, tu n'as indiqué clairement que dans ton dernier message que tu étais en stretch. Et si tu te relis, tu verras qu'avant ce message, tu n'as jamais indiqué ta version de debian. Donc en somme : je n'ai pas cherché à t'asticoter ou te démontrer quoi que ce soit, j'ai juste essayé de te répondre normalement. Libre à toi quand tu t'exprimes sur un forum de donner toutes les informations utiles pour avoir des réponses aussi pertinentes que possibles.

Bonne continuation.
Commenter la réponse de MAH
0
Merci
tu n'as jamais indiqué ta version de debian.

Tu as raison, méa-culpa !
En fait j'ai MX 18.1 qui est basé sur debian stretch, et dans les dépots, c'est la version STK 9.3 qui est présente, et aucune autre.
Je n'ai pas réussi à installer la version 8.2, celle que j'ai trouvé sur sourceforge ne s'installe pas, manque des dépendances.
la version 8 est sans installation car portable.
@+
mamiemando
Messages postés
28764
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
21 mars 2019
7999 -
Pas de problème ;-) Bonne continuation !
Commenter la réponse de MAH