Menu

NB.SI avec des cellules

Messages postés
4
Date d'inscription
samedi 9 mars 2019
Dernière intervention
18 mars 2019
-
Bonjour,

Sous Excel 2013, je cherche une formule permettant de compter les cellules (en NB.SI a priori) en fonction de plusieurs critères sur une plage de données d'un autre onglet :
- N° de semaine (que je calcule dans la colonne G d'un autre onglet)
- type d'anomalie (qui apparaît dans la colonne A de l'autre onglet)
- 3 cellules par ligne qui doivent être non vides pour que le NB.SI les prenne en compte.

J'ai fait des recherches et j'ai essayé de bidouiller de mon côté mais je n'ai pas réussi à avoir ce que je voulais. Auriez-vous une idée ?

Merci de votre aide.
Afficher la suite 

Votre réponse

3 réponses

Meilleure réponse
Messages postés
481
Date d'inscription
mardi 5 juin 2018
Dernière intervention
25 mars 2019
35
2
Merci
Bonjour,

Au lieu de rester dans les généralités, donne précisément les plages de cellules avec leurs feuilles et ce que tu cherches.

Cordialement.

Daniel

Dire « Merci » 2

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 46536 internautes nous ont dit merci ce mois-ci

Commenter la réponse de danielc0
Messages postés
251
Date d'inscription
samedi 2 février 2019
Dernière intervention
25 mars 2019
22
1
Merci
Bonsoir,
avec le peu d'information, voici un début de formule :
=NB.SI(Feuil1!G:G;10)+NB.SI(Feuil1!A:A;"a")
Et pour que tu comprennes mieux la formule avec le Feuil1 le 10 et le "a" :


Commenter la réponse de Yoyo01000
Messages postés
4
Date d'inscription
samedi 9 mars 2019
Dernière intervention
18 mars 2019
0
Merci
Bonjour,

je n'ai pas été très clair, alors j'essaie de me rattraper :


Je cherche à calculer le nombre d'anomalies de type A pour lesquelles les valeurs 1, 2 et 3 sont remplies, ici 0.
danielc0
Messages postés
481
Date d'inscription
mardi 5 juin 2018
Dernière intervention
25 mars 2019
35 -
Avec "type" en A1 :

=SOMMEPROD((A2:A7="A")*(B2:B7>0)*(C2:C7>0)*(D2:D7>0))

ou

=NB.SI.ENS(A2:A7;"a";B2:B7;">0";C2:C7;">0";D2:D7;">0")

Daniel
Commenter la réponse de temesias