Menu

Excel 2007, groupes de conditions "SI" [Résolu]

Messages postés
5
Date d'inscription
samedi 9 mars 2019
Dernière intervention
11 mars 2019
- - Dernière réponse : papy-ions
Messages postés
5
Date d'inscription
samedi 9 mars 2019
Dernière intervention
11 mars 2019
- 11 mars 2019 à 09:37
Bonjour, à la communauté,
J’ai 50 armoires numérotées de 1 à 50. Chaque armoire comporte des tiroirs, numérotés.
L’armoire numéro 1, a les tiroirs de1 à 5.L’armoire numéro 2, les tiroirs, de 6 à8.L’armoire numéro 3, a les tiroirs de 9 à 14, et ainsi de suite.
Sur Excel j’ai voulu utiliser les conditions « SI », par groupes, de 7.
=SI(G6<=5;1;SI(G6<=8;2;SI(G6<=14;3;SI(G6<=16;4;SI(G6<=19;5;SI(G6<=26;6;SI(G6<=30;7))))))
Avec ce groupe, de « SI » je rentre un numéro de tiroir en cellule G6, j’obtiens son numéro, d’armoire, ça marche. Si j’ajoute des conditions, après la 7eme.
=SI(G6<=5;1;SI(G6<=8;2;SI(G6<=14;3;SI(G6<=16;4;SI(G6<=19;5;SI(G6<=26;6;SI(G6<=30;7;)))))))&SI(G6<=32;8;SI(G6<=39;9;SI(G6<=45;10;)))
Après avoir ajouté des conditions, après la7eme, ça ne marche plus, pour les 7 premières conditions.
Le résultat 1, devient 18, le 2 devient 28, le 3, devient 38… Par cotre la 8eme, donne 8, la 9eme donne 9, la 10eme donne 10.
J’apprécie beaucoup Excel 2007, mais ne suis pas expert des formules longues.
Mes lunettes commencent à fumer, y aurait-il un pompier, bon œil (informatique), qui pourrait, les éteindre, en corrigeant, ma formule, qui ne marche pas ?
Grand merci, à vous.
Afficher la suite 

Votre réponse

6 réponses

Meilleure réponse
Messages postés
24659
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
11 mars 2019
8981
1
Merci
Bonjour,

Comme l'indique Vaucluse, il faut imbriquer les SI. Mais si 10 cela va encore, 50 ...

On peut rajouter une feuille avec les paramètres des armoires :


Et utiliser la formule
=RECHERCHEV(G6;Armoires!A2:B6;2;VRAI) 
pour déterminer l'armoire correspondant à G6. A adapter avec les paramètres des 50 armoires.

Cdlt

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 51344 internautes nous ont dit merci ce mois-ci

Commenter la réponse de jee pee
Messages postés
23607
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
10 mars 2019
5668
0
Merci
Bonjour
le problème est que après le signe & les conditions redémarrent à 0 et donc traitent le <32 comme le < 18
il faudrait donc écrire dans la seconde partie
...................&SI(ET( G6>30;G6<=32;SI(ET(G6>32;G6 etc...)
Mais si vous avez Excel 2007, le nombre de SI n'est pas limité.Placez les tous à la suite les uns des autres sans le signe &
=SI(G6<=5;1;SI(G6<=8;2;SI(G6<=14;3;SI(G6<=16;4;SI(G6<=19;5;SI(G6<=26;6;SI(G6<=30;7;SI(G6<=32;8;SI(G6<=39;9;SI(G6<=45;10;)))))))))
crdlmnt
papy-ions
Messages postés
5
Date d'inscription
samedi 9 mars 2019
Dernière intervention
11 mars 2019
-
Merci beaucoup, Vaucluse, je vais tester lundi.
Bonne journée, à vous.
Commenter la réponse de Vaucluse
Messages postés
5
Date d'inscription
samedi 9 mars 2019
Dernière intervention
11 mars 2019
0
Merci
Merci beaucoup, pour votre aide, je vais tester, en début de semaine. bonne journée, à vous.
Commenter la réponse de papy-ions
Messages postés
7657
Date d'inscription
dimanche 13 juin 2010
Dernière intervention
10 mars 2019
1656
0
Merci
Bonjour,

Ou avec Equiv et une table de correspondance :


Exemple :
https://mon-partage.fr/f/lT9s4XM7/
Commenter la réponse de Patrice33740
Messages postés
5
Date d'inscription
samedi 9 mars 2019
Dernière intervention
11 mars 2019
0
Merci
Bonjour et merci beaucoup, Patrice.
Actuellement, je prépare, la méthode de Vaucluse, pour la tester, pour mes 50 armoires. Merci, à vous trois, pour votre aide, précieuse.
Commenter la réponse de papy-ions
Messages postés
5
Date d'inscription
samedi 9 mars 2019
Dernière intervention
11 mars 2019
0
Merci
Bonjour,
Merci Vaucluse, maintenant, mes armoires ne sont plus anonymes, problème résolu.
Merci, également, à Je Pee, et Patrice, je vais tester vos méthodes.
Bonne journée, à tous.
Commenter la réponse de papy-ions