Menu

Enlever SSD RAID sans formater

- - Dernière réponse :  Alex - 11 mars 2019 à 19:16
Bonjour,

J'ai 3 disques dur sur mon ordinateur, soit 2 SSD l'un de 128go, d'origine dans l'ordinateur + un 256Go acheté il y a 2 ans. L'autre étant un HDD ordinaire on n'en parle pas.

Un jour j'ai fait un clone de mon 128Go sur mon 256Go pour avoir plus d'espace sur mon disque dur principal. Tout allait bien jusqu'à ce qu'un jour mon ordinateur décide de ne plus vouloir booter sur Windows. J'ai donc pensé à ce moment là que ça devait être le fait que je n'aille pas changé les fils pour mettre le 256Go sur le SATA1 et le 128Go sur SATA2. J'ai fait la manoeuvre et je me suis rendu compte que ce n'était pas le problème, bref, reconnecte tout comme avant, rien ne fonctionnait. Enfin, j'ai fait plusieurs essaie pour me rendre compte au final que dans mon bios, c'est écrit comme si mes SSD étaient en RAID, alors j'ai tenté de changer ce setting pour le mettre en AHCI, l'ordinateur ne voulait pas booter.

Alors je me dis qu'il y a un rapport entre le fait que mon SSD 256Go n'est pas reconnu en tant que disque principal et le fait que ce soit en RAID dans le bios. Pourtant, les 2 disques sont totalement distincts dans Windows, donc, je ne comprend pas pourquoi c'est écrit RAID dans le bios et que si je change le setting, l'ordinateur ne boote plus ...

Donc ultimement, je me demande si je peux réparer ce problème sans formater.

Merci de l'aide :)

Configuration: Windows / Chrome 72.0.3626.121
Afficher la suite 

Votre réponse

1 réponse

Messages postés
11035
Date d'inscription
lundi 28 octobre 2013
Statut
Contributeur
Dernière intervention
11 mars 2019
1740
0
Merci
Bonjour
Le fait qu'il soit écrit RAID dans le BIOS ne signifie pas forcément que vos disques font partie d'un RAID .
Mais que le controlleur est paramétré en mode RAID .
Ce qui fait que les pilotes du controlleur RAID ont été installés.

Pour essayer de démarrer sur le disque ,il faut :
-Paramétrer le controleur en mode RAID , et non AHCI
-Indiquer de bouter sur le disque dans le boot menu .

Malgré tout ,il est possible que votre disque ait un probleme
Oui, en fait, il n'y a plus de disque dur détecté dans le boot menu si je déconnecte le 128Go, un peu comme s'il n'y avait plus de boot sector sur mon 256Go ou quelque chose du genre ...

Merci :)
flo88
Messages postés
20060
Date d'inscription
dimanche 15 mai 2005
Statut
Contributeur
Dernière intervention
11 mars 2019
4039 -
Salut

Il en effet possible que le secteur de boot soit sur un disque et que windows se lance sur l'autre, ceci dit, suivant l'ancienneté de la carte mère c'est sur le HDD que windows va aller écrire sont MBR.......en priorité.
Est-ce que tu as modifié quelque chose matériellement à ce niveau ?
> flo88
Messages postés
20060
Date d'inscription
dimanche 15 mai 2005
Statut
Contributeur
Dernière intervention
11 mars 2019
-
Il n'y a aucun disque dur détecté dans le boot menu lorsque je déconnecte le 128Go donc, le MBR n'est pas sur le HDD sinon, il détecterait le HDD lorsque je déconnecte le 128Go, à tout le moins l'ordinateur ne booterait pas si le HDD était déconnecter, mais l'ordinateur fonctionne avec seulement le 128 Go connecté disons alors c'est comme s'il n'y avait aucun boot sur les 2 autres ...
flo88
Messages postés
20060
Date d'inscription
dimanche 15 mai 2005
Statut
Contributeur
Dernière intervention
11 mars 2019
4039 -
Alors il s'agit du choix de l'ordre de boot et de l'unité .
Certain bios ont deux paramètres sur ce sujet, l'ordre de boot que tout le monde connait et un autre qui définis l'unité de stockage à prendre en compte en premier, (hard drive priority), c'est là qu'entre peut-etre en jeux ton paramtétrage en RAID.....
Il faut mettre ton SSD en 1° dans les deux lignes, elles ne sont pas au même endroits.
C'est quoi la marque et modèle de ta carte mère ?
asus cg8270 c'est un ordinateur qui date d'environ 6 ans ...
Commenter la réponse de phil2k