Menu

Somme conditionnelle horizontal/vertical Excel 365 [Résolu]

Messages postés
3
Date d'inscription
mardi 5 mars 2019
Dernière intervention
5 mars 2019
- - Dernière réponse : Vince7492
Messages postés
3
Date d'inscription
mardi 5 mars 2019
Dernière intervention
5 mars 2019
- 5 mars 2019 à 13:49
Bonjour,

Je n'ai pas vu de problème similaire au mien donc je vous pose la question:
J'ai un onglet excel avec :
- en ligne 1 mes quantités (variable car rappelle d'un autres onglet)
- chacune des lignes C2 à C250 correspondent a des quantités spécifique en fonction du contenant
- ma colonne A correspond aux contenants (bouteilles/poches...)
- ma colonne B à la somme des colonne C à AG, multiplier par la ligne 1 (somme des contenant en fonction des quantités)

J'ai utilisé en B2 =Somme( C1*C2+D1*D2+... ) mais ayant trop de colonne, c'est long et fastidieux. Est ce qu'il existe une formule pour faire en sorte de le faire automatiquement?
Je souhaite tirer cette formule sur toute ma colonne B.



Avez vous une idée?
Je peux vous fournir un tableau si besoin pour être plus claire


Merci a vous :)
Afficher la suite 

Votre réponse

2 réponses

Meilleure réponse
Messages postés
23604
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 mars 2019
5666
2
Merci
Bonjour
voyez avec, en B2:
=SOMMEPROD(($C$1:$AG$1)*(C2:AG2))
crdlmnt

Dire « Merci » 2

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 51830 internautes nous ont dit merci ce mois-ci

Vince7492
Messages postés
3
Date d'inscription
mardi 5 mars 2019
Dernière intervention
5 mars 2019
-
Bonjour,

Parfait!!
Merci bien, j'ai pas pensé à utiliser cette formule, j'ai essayé ça fonctionne.

Bonne journée
Commenter la réponse de Vaucluse
0
Merci
Bonjour Vince 7492,

Es tu certain de tes numéros de ligne car tu écrits; J'ai utilisé en B2 =Somme( C1*C2+D1*D2+... ) , a la vue de ton tableau ta formule se trouve en B3 et à la place de C2 et D2 qui sont des cellules vides ce devrait être C3 et D3

papychipie
Vince7492
Messages postés
3
Date d'inscription
mardi 5 mars 2019
Dernière intervention
5 mars 2019
-
Bonjour Papychipie,
Effectivement j'ai sauté une ligne dans mon tableau c'est bien en ligne 3
Commenter la réponse de papychipie