Somme.si avec critères et plage sur la même ligne. [Résolu]

- - Dernière réponse : Vaucluse
Messages postés
24401
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 septembre 2019
- 5 mars 2019 à 09:43
Bonjour,
Je propose plusieurs formations à des salariés. Je souhaite suivre les paiements et faire des totaux par salarié sur Excel.
J'ai donc fait un tableur avec les salariés (colonne A, à partir de la ligne 3), leur structure (colonne B, à partir de la ligne 3). Ainsi que le nom des factures (facture formation 1, facture formation 2, facture formation3) en cases C2, E2, G2. Dans les colonnes C,E,G je met le montant des factures.
J'ai mis en cases D2, F2, H2, le mot OK si ils ont payé et rien si ils n'ont pas payé.

J'arrive à faire le total du montant des factures réglées et non réglées sur la globalité des salariés, mais je n'arrive pas à le faire par salarié. Surement parce que la formule "somme.si" ne fonctionne pas si la plage et les critères sont sur la même ligne
Pouvez-vous me donner quelque astuces ?

Merci.
Configuration: Windows / Firefox 65.0
Afficher la suite 

2 réponses

Messages postés
2465
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
22 septembre 2019
273
0
Merci
Bonjour,

en colonne G, par exemple
en g2=somme(C2; E2; G2 ) ou bien somme(C2: G2 )
Avec somme() excel ne compte que les nombres.


Crdlmt
-
En effet, merci beaucoup, cependant j'ai oublié une information importante, je souhaite avoir les totaux payés et restant a payer pour chaque salarié. Lorsqu'une facture n'est pas réglée le montant est indiqué dans les cases, ce qui m'indique un total faussé, je veux dissocier payé et non payé (Au fait, C2 E2 G2 sont des titres)
Commenter la réponse de DjiDji59430
Messages postés
24401
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 septembre 2019
4769
0
Merci
Bonjour
ce n'est pas la meilleure configuration pour utiliser Excel
en principe, la formule SOMME.SI fonctionne quand même si vous décalez les champs d'une valeur constante, et si vous n'avez pas d'autres valeurs numériques dans la champ que celles à sommer:
exemple:

texte cherché toutes les quatre colonnes à partir de A3 =jusqu'à U3
somme à prendre en compte décaler de trois cellules de D3 à X3
la formule
=SOMME.SI(A3:U3;"texte cherché"7;D3:X3)

crdlmnt

Vaucluse
Messages postés
24401
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 septembre 2019
4769 -
ok, alors à demain si personne d'autre n'intervient. Je ferme pour ce soir
-
Et voici : https://mon-partage.fr/f/f7wuieCH/
Vaucluse
Messages postés
24401
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 septembre 2019
4769 -
alors comme ça?
https://mon-partage.fr/f/JGzBYNo5/
crdlmnt
-
C'est parfait, merci beaucoup ! Ma question est résolue.
Je vous remercie pour votre aide.
Vaucluse
Messages postés
24401
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 septembre 2019
4769 -
pas de quoi
je passe le sujet en résolu
Bonne route
crdlmnt
Commenter la réponse de Vaucluse