Menu

Je cherche les chiffres qui ont 10 chiffres comme premiers

Messages postés
557
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
31 mai 2019
-
Bonjour,
j'ai cette formule qu'est applicable sur 3 chiffres, je recois la somme de ses correspondance:

si j'ai des colonnes A / B:

123888/2
123999/2
123777/1

La formule : =SOMMEPROD((GAUCHE($A$1:$A$13;NBCAR($C$1))=SI(ESTTEXTE(C1);C1;CTXT(C1;0)))*($A$1:$A$13<>"")*($B$1:$B$13))

le resultat est 5.

je veux que cette formule soit applicable sur 10 chiffres premiers 1234567899nnnnn

Merci infiniment,


Configuration: Windows / Firefox 52.0
Afficher la suite 

2 réponses

Meilleure réponse
Messages postés
1930
Date d'inscription
mercredi 27 juillet 2005
Statut
Membre
Dernière intervention
31 mai 2019
744
2
Merci
Bonsoir à tous,

Tu supprimes les $ dans la référence $C$1 puis tu rajoutes le paramètre ;VRAI dans CTXT()

Cordialement

Dire « Merci » 2

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 42772 internautes nous ont dit merci ce mois-ci

nonossov
Messages postés
557
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
31 mai 2019
-
je n'ai pas compris ! est ce que vous pouve m'aider a monter cette formule????
JvDo
Messages postés
1930
Date d'inscription
mercredi 27 juillet 2005
Statut
Membre
Dernière intervention
31 mai 2019
744 -
bonjour,

tu n'as qu'une formule dans ton fichier !!! (marque d'agacement) :
=SOMMEPROD((GAUCHE($A$1:$A$13;NBCAR($C$1))=SI(ESTTEXTE(C1);C1;CTXT(C1;0)))*($A$1:$A$13<>"")*($B$1:$B$13))

tu fais les remplacements que je t'ai proposés et tu obtiens :
=SOMMEPROD((GAUCHE($A$1:$A$13;NBCAR(C1))=SI(ESTTEXTE(C1);C1;CTXT(C1;0;VRAI)))*($A$1:$A$13<>"")*($B$1:$B$13))

maintenant tu peux recopier D1 sur D5 et tu verras le résultat attendu.

Les $ dans une référence de cellule figent soit la ligne, soit la colonne, soit les deux.
Si tu ne les retires pas de NBCAR($C$1), les formules que tu recopieras dans ta feuille feront toujours référence à la cellule C1.
Ce n'est pas a priori ce que tu souhaites.

Le paramètre VRAI dans la fonction CTXT() permet d'éliminer les séparateurs de milliers qui gênaient l'obtention du bon résultat vu que tu comparais "4411332255" (là, il n'y a pas d'espaces) à 4 411 332 255 (là, espaces il y a).

cdlt
Commenter la réponse de JvDo
Messages postés
58578
Date d'inscription
mardi 8 janvier 2008
Statut
Modérateur
Dernière intervention
13 mai 2019
4583
0
Merci
Bonjour,

Je connaissais le nombre Pi (Π) mais pas les chiffres ki...

Les nombres que tu donnes en exemple ne sont pas premiers ! Veux-tu parler des 10 premiers chiffres qui composent un nombre ?
nonossov
Messages postés
557
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
31 mai 2019
-
Merci de voir ce fichier pour avoir une aidé claire:
NB: Cette formule est valable pour 3 chiffres premiers

https://www.cjoint.com/c/ICepHlgJ6Fc
Chris 94
Messages postés
58578
Date d'inscription
mardi 8 janvier 2008
Statut
Modérateur
Dernière intervention
13 mai 2019
4583 -
Je ne suis pas sûr du tout de pouvoir t'aider sur ton problème précis... Mais celui-ci est imprécis car on ne sait pas ce que tu appelles "les chiffres premiers".

Rappel : un nombre premier n'est divisible que par 1 et par lui-même :
             2, 3, 5, 7, 11, 13,...., 49999,... sont premiers.
            4, 6, 8, 9,... tes exemples ne sont pas premiers.
nonossov
Messages postés
557
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
31 mai 2019
-
voila un exemple simple:

https://www.cjoint.com/c/ICeqS45ExYc
nonossov
Messages postés
557
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
31 mai 2019
-
nonossov
Messages postés
557
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
31 mai 2019
-
Merci de m'aider SVP
Commenter la réponse de Chris 94