Menu

Badgeage

Messages postés
5
Date d'inscription
lundi 4 mars 2019
Dernière intervention
6 mars 2019
- - Dernière réponse : eriiic
Messages postés
22481
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
7 mars 2019
- 6 mars 2019 à 16:43
bonjour ,

Sur le fichier Excel, j'ai besoin de connaître le nbre de badgeage par jour et par personne,

et aussi le temps global par jour et par personne des temps entre les badgeages SORTIE et les ]badgeages ENTREE
merci de votre aide


badgeages ENTREE
Afficher la suite 

Votre réponse

9 réponses

Messages postés
1667
Date d'inscription
jeudi 2 juillet 2015
Dernière intervention
7 mars 2019
592
0
Merci
Bonjour,

Pour comptez le nombre de fois qu'un badge est utilisé vous pouvez utiliser la fonction NB.SI.

Exemple:
=NB.SI(A:A;"Toto")

Vous pouvez passez par le numéro de badge, et également passé par un onlget qui fera le recap.

Pour savoir combien d'heure:
=SOMMEPROD((A2:A9="Toto")*(G2:G9-E2:E9))

Vous ne pouvez pas excéder les 24h si je me trompe pas .



Commenter la réponse de diablo13800
Messages postés
5
Date d'inscription
lundi 4 mars 2019
Dernière intervention
6 mars 2019
0
Merci
merci pour votre aide, Diablo 13800 ;
La difficulté, c'est que mon fichier réel comporte des milliers de ligne (année 2012), et il faut que le temps global apparaisse en ligne et cela par chaque individu distinct(ici 4) et ce pour chaque jour .

Autrement dit: Excel doit creer un fichier ou sur chaque ligne on retrouvera le nom distinct, le prénom, le badge, la date entrée, la date de sortie, le tps hors badgeage.


Merci pour vitre aide précieuse




,
Commenter la réponse de CHOMB38
Messages postés
22481
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
7 mars 2019
7236
0
Merci
Bonjour,

ajoute une colonne pour calculer le temps, puis un TCD te fera tout le reste.
Tableau Croisé Dynamique (TCD) : http://www.mdf-xlpages.com/modules/smartsection/item.php?itemid=109
et
http://www.mdf-xlpages.com/modules/publisher/item.php?itemid=130
eric
Commenter la réponse de eriiic
Messages postés
5
Date d'inscription
lundi 4 mars 2019
Dernière intervention
6 mars 2019
0
Merci
Merci ERIC,


rajouter une colonne, cela, je sais faire. Mais quelle formule je dois mettre dedans?

Mon besoin est d'avoir, pour chaque personne distinct, le temps hors badgeage et ce pour chaque jour.


Une personne peut avoir badgée plusieurs Entrée et Sortie, dans la même journée


Les TCD, je ne suis pas expert en la matière, loin de là!! Je connais les TCD très peu.



Si tu pouvais m'éclairer !!


Merci Eric
eriiic
Messages postés
22481
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
7 mars 2019
7236 -
pour la formule merci de déposer le fichier xls (réduit au nécessaire et anonymisé) sur cjoint.com et coller ici le lien fourni.

Les TCD, je ne suis pas expert en la matière, loin de là!! Je connais les TCD très peu.
tu as donc toutes les raisons d'aller lire les liens que j'ai mis. Je n'expliquerai pas mieux.
eric
Commenter la réponse de CHOMB38
Messages postés
5
Date d'inscription
lundi 4 mars 2019
Dernière intervention
6 mars 2019
0
Merci
merci Eric, ci joints les fichiers

https://www.cjoint.com/c/ICgjiRUkwKr

https://www.cjoint.com/c/ICgjkIvH48r


https://www.cjoint.com/c/ICgjlKdeHzr


je n'arrive pas avec les TCD, aussi je joint le fichier de pointage, le fichier de la journée du 2 février qui est issu du fichier de pointage, et l'exemple de ce que je voudrai



merci pour ton aide
Commenter la réponse de CHOMB38
Messages postés
22481
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
7 mars 2019
7236
0
Merci
Bonjour,

une des raison pour lesquelles tu n'y arrivais pas, c'est que tu calcules des date en les laissant en texte et non en numérique.
Pour excel un texte est un texte, pas une date, même si c'est écrit "01/02/2018".
Pour t'y retrouver arrête de mettre un alignement sur tes colonne : à gauche c'est du texte, à droite c'est un numérique.
J'ai donc repris quelques une de tes formules, et ajouté une colonne pour avoir le temps d'absence en numérique.
https://www.cjoint.com/c/ICglZzU5yO6
eric
Commenter la réponse de eriiic
0
Merci
Franchement Super,

encore merci pour ton aide
Commenter la réponse de CHOMB38
Messages postés
5
Date d'inscription
lundi 4 mars 2019
Dernière intervention
6 mars 2019
0
Merci
OUPS, j'ai crié victoire trop vite. En effet, la colonne Absence que tu as rajouté, c'est le temps passé à travailler de la colonne n° 2


Ce n'est pas l'Absence de l'entreprise qui doit être égal au temps mesuré entre une Sortie et une Entrée
.Une personne qui badge qu'une seule fois n'a pas d'absence. Il faut au moins 2 badgeages pour pouvoir mesurer le temps entre une Sortie 1 et une Entrée 2.


Merci de m'aider encore!!.
eriiic
Messages postés
22481
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
7 mars 2019
7236 -
Si tu veux.
Mais comment détermines-tu si c'est une sortie absence ou une sortie normale ? A partir du moment où certains travaillent de nuit on ne peut se baser sur le fait que l'entrée suivante a lieu le lendemain.
Il faut que tu fournisses la règle infaillible.
eric
eriiic
Messages postés
22481
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
7 mars 2019
7236 -
PS :
on peut également difficilement se baser sur le temps minimum entre 2 journées de travail qui est de 11h quand on voit ça :
BOSTIC 0:29:33 9862 / 011900 14/02/2012 13:15 14/02/2012 13:45
BOSTIC 0:24:00 9862 / 011900 14/02/2012 21:02 14/02/2012 21:26
7:17 d'absence ?
eric
eriiic
Messages postés
22481
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
7 mars 2019
7236 -
En attendant, avec une formule qui compte les absences <11h
https://www.cjoint.com/c/ICgpOpbZyc6
à toi de l'adapter à ton besoin.
eric
Commenter la réponse de CHOMB38
0
Merci
Bonjour Eric

La règle est la suivante:


Dans une même journée, dès que la personne bagde au moins 2 fois je dois mesurer le temps entre l'Entrée 2 et la Sortie 1
Si la personne bagde au moins 3 fois je dois mesurer le temps entre l'Entrée 2 et la Sortie 1+ le temps entre l'Entrée 3 et la Sortie 2 ....etc
Si le terme absence n'est pas approprié on peut mettre 'Mesure entre les Sorties et les Entrées'

Merci encore.
Commenter la réponse de Chomb38