Menu

Recherchev avec une partie du contenue d'une cellule [Résolu]

Messages postés
10
Date d'inscription
vendredi 1 mars 2019
Statut
Membre
Dernière intervention
14 mars 2019
- - Dernière réponse : danielc0
Messages postés
498
Date d'inscription
mardi 5 juin 2018
Statut
Membre
Dernière intervention
23 mai 2019
- 1 mars 2019 à 16:21
Bonjour

C'est pour faire une recherchev avec une partie du contenue de la cellule.
j'ai une colonne avec des numéro de département et une autre colonne à coté avec les villes de ces départements.
L'idée est de mettre une recherche dans une cellule a coté :
si par exemple j'ai
42177 POUILLY-SOUS-CHARLIEU
dans une autre cellule j'entre juste 42 et il me sorts POUILLY-SOUS-CHARLIEU et toutes autre villes dont le code commence par 42. Pareil si j'entre par exemple 77 il me sorts toutes les villes dont le code on trouve 77 voila
Merci de votre aide.
Afficher la suite 

Votre réponse

1 réponse

Messages postés
498
Date d'inscription
mardi 5 juin 2018
Statut
Membre
Dernière intervention
23 mai 2019
36
0
Merci
Bonjour,

Est-ce que tu veux dire que tu as une table avec les codes postaux et les villes ?

Daniel
danielc0
Messages postés
498
Date d'inscription
mardi 5 juin 2018
Statut
Membre
Dernière intervention
23 mai 2019
36 > Hicham-Mor
Messages postés
10
Date d'inscription
vendredi 1 mars 2019
Statut
Membre
Dernière intervention
14 mars 2019
-
Je ne sais pas le faire en mettant tous les noms dans la même cellule. Je sais en faire la liste dans une plage de cellules en colonne. est-ce ce que tu veux ?

Daniel
Hicham-Mor
Messages postés
10
Date d'inscription
vendredi 1 mars 2019
Statut
Membre
Dernière intervention
14 mars 2019
-
oui biensur, aprés je verrai comment l'adapter. Merci
danielc0
Messages postés
498
Date d'inscription
mardi 5 juin 2018
Statut
Membre
Dernière intervention
23 mai 2019
36 > Hicham-Mor
Messages postés
10
Date d'inscription
vendredi 1 mars 2019
Statut
Membre
Dernière intervention
14 mars 2019
-
Pour plus de compréhension, j'ai tout mis sur la même feuille. Les codes postauxx en colonne A, Les villes en colonne B, le département en F1. En H1, à recopier vers le bas :
=SIERREUR(INDEX($B$1:$B$12;AGREGAT(15;6;(1/(GAUCHE($A$1:$A$12;2)=CTXT($F$1;0)))*LIGNE($A$1:$A$12);LIGNE(A1)));"")



Daniel
Hicham-Mor
Messages postés
10
Date d'inscription
vendredi 1 mars 2019
Statut
Membre
Dernière intervention
14 mars 2019
-
Magnifique Merci bcp

Il y'a par contre un seul souci : Si la personne entre le numéro de département en entier (01400 au lieu de 01) on a aucun résultat.
Si vous pensez trouver la solution rapidement c'est ok si non ne vous cassez pas la tete.

Merci bcp .
danielc0
Messages postés
498
Date d'inscription
mardi 5 juin 2018
Statut
Membre
Dernière intervention
23 mai 2019
36 > Hicham-Mor
Messages postés
10
Date d'inscription
vendredi 1 mars 2019
Statut
Membre
Dernière intervention
14 mars 2019
-
=SIERREUR(INDEX($B$1:$B$12;AGREGAT(15;6;(1/(GAUCHE($A$1:$A$12;NBCAR($F$1))=TEXTE($F$1;REPT("0";NBCAR($F$1)))))*LIGNE($A$1:$A$12);LIGNE(A1)));"")

Daniel
Commenter la réponse de danielc0