Formule [Fermé]

Signaler
Messages postés
14
Date d'inscription
vendredi 7 août 2009
Statut
Membre
Dernière intervention
16 février 2020
-
Messages postés
2612
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
9 avril 2020
-
J'aimerais savoir pourquoi ma formule NB.SI.ENS(C3:C55;D3:D55;"PRAIRIE") ne fonctionne pas.
1ère série (C3:c55) = une série de chiffre
2ème série (D3:D55)= , PRAIRIE, BLE, MAIS, ORGE
Je voudrais que la formule me calcule le nombre total par rapport à chaque catégorie (prairie, mais, orge etc) . Il y a une erreur dans ma formule et impossible de la trouver. merci pour vos conseils

2 réponses

Messages postés
2508
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
9 avril 2020
586
Bonjour,

Si tu cherches ne nombre de fois où chaque catégorie est inscrite ; juste un

NB.SI(D3:D55;"PRAIRIE")

Pour la somme des nombres en C par rapport à chaque catégorie ;

=SOMME.SI(D3:D55;"PRAIRIE";C3:C55)
ou
=SOMMEPROD((D3:D55="PRAIRIE")*(C3:C55))

Enfin si j'ai bien compris la demande

Cordialement
Messages postés
2612
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
9 avril 2020
326
Bonjour,

Utilise plutot :
=sommeprod(($D$3:$D$55="prairie")*($C$3:$C$55))

Ta formule NB.SI.ENS(C3:C55;D3:D55;"PRAIRIE") ne veut rien dire la syntaxe est
NB.SI.ENS(plage_critères1; critères1; [plage_critères2; critères2]…) et ne ressemble en rien a la tienne.
Ma formule te calcule la somme des nombres en C3:c55 pour le texte "prairie" en$D$3:$D$55


Crdlmt