Menu

Formule échéancier

Messages postés
2
Date d'inscription
lundi 25 février 2019
Statut
Membre
Dernière intervention
26 février 2019
- - Dernière réponse : DjiDji59430
Messages postés
2399
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
10 juin 2019
- 26 févr. 2019 à 11:05
Bonjour,

Alors je vais essayer de vous expliquez mon problème le plus clairement possible, en espérant que vous puissiez m'aider.
Je dois crée un tableau d'échéance avec diverses formules. Sauf que je rencontre plusieurs difficultés.

Vous trouverez ci-joint mon fichier excel.

https://www.cjoint.com/c/IBzkXl7ip6t

Tout d'abord j'ai utilisé la formule suivante:

=SI(ET(J12<>"";(AUJOURDHUI())-J12>30);"Relance";"")
Cette formule me permet d'avoir le mot relance celons la date d'émission de la facture. Mais comme vous pouvez le constater même si la date de relance est < a 30 jours , la formule me laisse tout de même relance.

Puis dans date de règlement de la première relance , j'ai la formule suivante :
=SI(ET(J12<>"";(AUJOURDHUI())-J12>30);"Relance";"")
cette formule me permet d'inscrire soit le mot relance est alors toutes les autres informations s'affichent dans la deuxième et troisième relance.
Alors que si je marque une date qui signifie que la facture est réglée toute les données s'enlèvent.
Mais pour que ces données s'enlèvent de toutes les autres cases j'ai du utiliser une autre formule inscrit dans les cases concernant la deuxième et troisième relance :
=SI(ESTERREUR(DATEVAL(TEXTE(M12;"jj-mm")));"Relance";"")

Elle marche super bien. Mais le soucis est que je souhaiterais non seulement avoir dans une case : si la date de règlement est inscrite dans la 1 ère relance alors les données inscrites dans la deuxième comme dans la troisième relance les données ne doivent plus s'afficher. Et je souhaiterais également le faire pour ma deuxième et troisième relance : si j'ai une date de réglèment alors le reste s'enlève.

J'espère que vous pourriez m'aider , et que j'étais assez claire, mais c'est assez compliqué de l'expliquer.

:p
Afficher la suite 

4 réponses

Meilleure réponse
Messages postés
5326
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
11 juin 2019
317
1
Merci
Bonjour

Vos dates sont sur l'année 2014 et la fonction aujoudhui() est sur l'année 2019 donc il y aura toujours plus de 30 jours

Il faudrait une colonne règlement avec la valeur et colonne date pour inscrire la date du règlement
Afin de pouvoir faire un contrôle de restant dû

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 42320 internautes nous ont dit merci ce mois-ci

Commenter la réponse de PHILOU10120
Messages postés
2399
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
10 juin 2019
260
1
Merci
Bonjour,

tiens, un essai a vérifier :

https://www.cjoint.com/c/IBzpnsyHsEc

Crdlmt

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 42320 internautes nous ont dit merci ce mois-ci

Commenter la réponse de DjiDji59430
Messages postés
2
Date d'inscription
lundi 25 février 2019
Statut
Membre
Dernière intervention
26 février 2019
0
Merci
Bonjour,

Merci a vous deux pour votre aide :D, donc pour répondre à vos réponses :

Philou :

-Je suis consciente que les années sont en 2014, mais cela ne change en rien, que les dates soient en 2014 ou 2019. Car la formule aujourd'hui ne prends tout de même pas en compte les dates inférieurs ou supérieurs à ma demande. ( Mais bon tant pis tout ne peux pas être parfait, le principal c'est que sa marche )

- En effet, par dépit j'ai rajouté une colonne afin que tous les éléments que je souhaite ne plus voir affiché lors de la rentré d'un montant dû, disparaisse, mais je dois suivre précisément le modèle élaborer sans rajout. J'ai tout de même trouver un formule qui réponds a mes attentes sans le passage de ce rajout.

DjiDji :

Je te remercie pour ton essaie :D.

Mais après toutes vos solutions, il me reste a savoir une seule chose :


- C'est de savoir comment combiner deux valeurs dans une formule prennent en compte ces deux valeurs...

Car le problème est que j'ai la formule suivante:

=SI(ESTERREUR(DATEVAL(TEXTE(M12;"jj-mm")));"Relance";"")

Niquel, quand je rentre une date dans M12 tous s'enlève , mais lorsque je rentre une date dans P12 qui est représentée comme ma deuxième relance, le mot relance ne s'enlève pas.

J'ai essayé de combiner les deux valeurs avec "&", afin que la formule prenne en considération l’enlèvement du mot relance mais cela ne fonctionne tout de même pas ..

Auriez vous une idée pour combiner ces deux valeurs ?

je vous remercie d'avance, et je vous joins une fois de plus mon fichier afin que vous puissiez voir de vous même le soucis exposé, et avoir un modelé d'échéancier qui marche presque entièrement :D


https://www.cjoint.com/c/IBAjudAmw7t
Commenter la réponse de Oceane_6478
Messages postés
2399
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
10 juin 2019
260
0
Merci
Re
Donne des exemples précis de ce qui ne fonctionne pas comme tu veux dans les fichiers réponses proposés.


Crdlmt
Commenter la réponse de DjiDji59430