Menu

[RESOLU]Impossible de trouver le gestionnaire audio CMedia

Messages postés
2
Date d'inscription
vendredi 22 février 2019
Statut
Membre
Dernière intervention
22 février 2019
-
Bonjour à tous,

J'ai un souci avec une carte son 7.1 USB utilisant CMedia.
Cela fonctionnait bien, mais depuis quelques jours je ne vois plus le gestionnaire audio dans la barre de tache (à coté de l’horloge).

Mon PC est équipé de 2 kit d'ampli audio, l'un 5.1 connecté directement sur ma carte mère. et l'autre 7.1 connecté sur la carte CMedia, pour regardé un filme sur la TV.

Depuis quelque temps j'ai plus le gestionnaire audio CMedia dans la barre de tache. Quand CMedia était activé (carte son branché) le gestionnaire realtek de ma carte mère disparaissait, mais maintenant il reste tout le temps.

Le seul moyen que j'ai trouvé c'est que je réinstalle le driver et logiciel CMedia CM6206-1.03(CR).
Cela désinstalle puis réinstalle (sans que j'accepte la demande de redémarrage), et la l'icone se trouve donc bien dans la barre des taches, je peux ouvrir le gestionnaire et faire les réglage.

Mais au redémarrage suivant je ne l'ai plus.

Quand je basculais de CMedia sur Realtek j'avais besoin de trouver le gestionnaire Realtek, mais je l'ai trouvé et fait j'ai fait un raccourci:
"C:\Program Files\Realtek\Audio\HDA\RtkNGUI64.exe"

Mais je ne trouve pas celui de CMedia.

J'ai constaté, après installation de CMedia, si je lance le gestionnaire depuis la barre de tache, un processus apparaît en plus dans le gestionnaire de taches. Mais ce processus est rundll32.exe, je peux ouvrir le processus et il a bien en enfant le "USB Multi-Channel Audio Device avec le logo de CMedia".


Donc c'est pas un exécutable, mais une dll qui est surement lancé par rundll32.exe. Par contre je ne sais pas ce qu'il lance, la ligne de commande associé au lancement du gestionnaire.

Lors de l'installation, une clef est créer dans la base de registre. Il y a plusieurs paramètres, mais un seul m'a attiré:
C:\\Program Files (x86)\\USB Multi-Channel Audio Device
Mais ce répertoire n'existe pas.
Il n'existe pas non plus dans :
C:\\Program Files\\USB Multi-Channel Audio Device

La clef de la BDR, m'indique aussi un emplacement,
"CMUninstallString"="C:\\Windows\\System32\\Cmeau106.exe /rm /pusb106"
J'ai bien ce fichier et il me desinstall le logiciel CMedia dans l’état.
Si je lance Cmeau106.exe cela me fait rien.
Il y a bien une dll dans le répertoire System fltr106.dll

La clef m'indique aussi l'icone:
"DisplayIcon"="C:\\Windows\\cmeau106.ico"

Avez-vous une idée ?

Merci
Afficher la suite 

Votre réponse

1 réponse

Messages postés
2
Date d'inscription
vendredi 22 février 2019
Statut
Membre
Dernière intervention
22 février 2019
0
Merci
Bon ba je me répond tout seul,

En analysant les fichiers présent avec l'icone, dans C:\Windows,

J'ai trouvé un cm106.ini.cfg

Il contient notamment:

[POSTRUNAPP_INSTALL_64]
%SETUPDIR%\Program\cmhotfix.exe -WAIT
%SETUPDIR%\Program\CmEnhance.exe "%HARDWAREID%" -WAIT
%SETUPDIR%\Program\CmElv64.exe "%WINDIR%\syswow64\RunDll32.exe %WINDIR%\Syswow64\cm106.dll,CMICtrlWnd"

Le SETUPDIR semble être celui de la base de registre. Donc C:\Program Files (x86)\USB Multi-Channel Audio Device

Je me suis concentré sur le 3 eme et j'ai donc créer un raccourci sur le bureau avec pour cible:
"C:\Program Files (x86)\USB Multi-Channel Audio Device\Program\CmElv64.exe" "%WINDIR%\syswow64\RunDll32.exe %WINDIR%\Syswow64\cm106.dll,CMICtrlWnd"

Bien sur j'ai créé "USB Multi-Channel Audio Device" et j'y est ajouté l'intégralité des fichiers du setup d'installation. Dedans il y a le dossier Program et les exécutables.

Du coup en cliquant sur ce raccourci j'ai de nouveau mon icone CMedia dans la barre de tache et donc j'ai Access au gestionnaire audio.

Je sais pas pourquoi cela marche plus tous seuls, mais bon cela me suffi comme cela.
Commenter la réponse de Makita37