Menu

Test logique "contient du texte" [Résolu]

Messages postés
3
Date d'inscription
mercredi 20 février 2019
Statut
Membre
Dernière intervention
20 février 2019
- - Dernière réponse : florencedcl
Messages postés
3
Date d'inscription
mercredi 20 février 2019
Statut
Membre
Dernière intervention
20 février 2019
- 20 févr. 2019 à 14:25
Bonjour,

J'aimerais faire une formule "si", avec comme test logique "si ma cellule contient du texte".
Comme dans mes cellules visées il existe des textes différents les unes entre les autres, j'aimerais savoir s'il existe une autre solution que de faire des "si" imbriqués pour chaque texte différent.

Par exemple, pour l'instant ma formule ressemble à ça, car j'avais simplement coché manuellement certaines cases en y mettant un x majuscule:

=SI(S11="X";"";175-R11-S11-T11)


Au lieu de devoir remplacer le x par les textes que j'ai remplacés, existe-t-il un moyen de noter "contient du texte" ?

Merci
Afficher la suite 

Votre réponse

2 réponses

Messages postés
1760
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
24 mai 2019
613
0
Merci
Bonjour,

Essayer la formule Esttexte()
=Si(ESTTEXTE(S11);"";175-R11-S11-T11)

A Vaincre sans péril, on triomphe sans gloire.
Pierre Corneille, Le Cid 
florencedcl
Messages postés
3
Date d'inscription
mercredi 20 février 2019
Statut
Membre
Dernière intervention
20 février 2019
-
C'est parfait, ça fonctionne !

Merci !
Commenter la réponse de diablo13800
Messages postés
77
Date d'inscription
lundi 19 décembre 2016
Statut
Membre
Dernière intervention
12 mars 2019
3
0
Merci
Bonjour ,

Tes cellules contiennent soit du texte , soit elles sont vides ?

Si oui, on peut passer par la formule : Si cellule différent de vide , alors ...

Ce qui donne
=SI(S11<>"";"coucou";"bonjour")
ici si C11 n'est pas vide (donc contient du texte) , alors la valeur renvoyé est coucou, sinon c'est bonjour.

Si tes cellules peuvent êtres autrement remplis par du texte (soit vide, soit texte, soit chiffre), je passe la main !
florencedcl
Messages postés
3
Date d'inscription
mercredi 20 février 2019
Statut
Membre
Dernière intervention
20 février 2019
-
Bonjour,

Merci pour cette réponse ! Je n'ai pas précisé, mais en effet les autres formules contiennent des chiffres. Je veux faire une somme des chiffres, mais pour certaines cellules Excel me sort #VALEUR comme il y a du texte
Commenter la réponse de Ducoduc