Formule trie [Résolu]

Messages postés
10
Date d'inscription
mardi 19 février 2019
Statut
Membre
Dernière intervention
20 février 2019
- - Dernière réponse : Factory26
Messages postés
10
Date d'inscription
mardi 19 février 2019
Statut
Membre
Dernière intervention
20 février 2019
- 20 févr. 2019 à 22:51
Bonjour,

j'ai un tableau avec 6 résultats je souhaite que dans ma colonne Total ça ne me prenne en compte que les 3 meilleurs sur les 6.
Qu'elle formule dois je utiliser ?
Merci d'avance

Configuration: Windows / Chrome 72.0.3626.109
Afficher la suite 

1 réponse

Messages postés
24213
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 juillet 2019
4681
0
Merci
Bonjour
pour un champ de A1 à A6, à adapter:
=SOMMEPROD((A1:A6>=GRANDE.VALEUR(A1:A6;3))*(A1:A6))
vous additionnera les éventuels ex-aequo autant de fois qu'ils sont présents dans la condition
crdlmnt

Vaucluse
Messages postés
24213
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 juillet 2019
4681 -
votre fichier en retour. A vérifier

en ligne 4:
  • j'ai défusionné les cellules
  • j'ai placé des X dans les cellules des colonnes à prendre en compte
  • ces X peuvent être masqués par une police de la même couler que le fond

les formules en X ou Y sont toujours matricielles

vous avez deux types de résultats selon le type de formule, c'est vous qui décidez
en colonne X, la formule donne le résultat de la somme des 4 plus grandes valeurs
en colonne Y la formule donne le cumul de toutes les valeurs égales ou supérieures à la 4°
vous pouvez voir la différence en X et Y 5 car la dernière valeur prise en considération est multiple dans le champ H5:V5
en X 80,8 n'est comptée qu'une fois
en Y 80,8 est comptée autant de fois qu'elle apparaît (donc deux fois)
https://mon-partage.fr/f/t9CRjOdw/

o noter que dans le cas ou la valeur multiple n'est pas la dernière, les deux formules donnent le même résultat

revenez si vous ne trouvez pas votre bonheur

crdlmnt
Factory26
Messages postés
10
Date d'inscription
mardi 19 février 2019
Statut
Membre
Dernière intervention
20 février 2019
-
Super.

Est-il possible d'avoir comme pour hier c'est à dire sans les X ou non ?
Factory26
Messages postés
10
Date d'inscription
mardi 19 février 2019
Statut
Membre
Dernière intervention
20 février 2019
-
en tout cas encore merci pour votre temps et patience
Vaucluse
Messages postés
24213
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 juillet 2019
4681 -
voila (dans la version un seul exemplaire du dernier si plusieurs équivalent)
https://mon-partage.fr/f/SwguLGeg/
crdlmnt
Factory26
Messages postés
10
Date d'inscription
mardi 19 février 2019
Statut
Membre
Dernière intervention
20 février 2019
-
Encore un grand merci
Commenter la réponse de Vaucluse