Menu

Copie de cellules [Résolu]

-
Bonjour,

Je dispose d’un fichier excel de 2 colonnes.

La premiere : Type d’activite
La deuxieme : Pourcentage

J’aimerai savoir si il est possible (avec une macro, ou simplement du code dans les cellules d’excel), je copie toutes les cellules différentes de 0 et les colle ailleurs sur la page et dans l’ordre croissant ou decroissant


Exemple

(Ce que j’ai de base) :

Type : Pourcentage :
A. 10%
B. 0%
C. 27%
D. 12%


(Ce que je veux obtenir) :

Type : Pourcentage :
C. 27%
D. 12%
A. 10%
Afficher la suite 

Votre réponse

4 réponses

Messages postés
10617
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
20 mai 2019
1404
0
Merci
Bonjour julien

Un exemple par formule en rajoutant d'abord une colonne pour calculer le rang de chaque type
https://mon-partage.fr/f/C1Lb9KQI/

Cdlmnt
Via
Commenter la réponse de via55
Messages postés
22
Date d'inscription
mardi 19 février 2019
Statut
Membre
Dernière intervention
10 avril 2019
0
Merci
Bonjour,

Tout d'abord merci pour votre réponse cela fonctionne correctement sauf certains points, est il possible de ne pas afficher les types qui sont à 0% ? ou alors si ce n'est pas possible, lorsque je test avec plusieurs types à 0% j'ai des erreurs,que dois-je modifier alors ?

Bien Cordialement
Commenter la réponse de JulienHch
Messages postés
10617
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
20 mai 2019
1404
0
Merci
Remplace la formule pour le rang par celle-ci
=SI(B2=0;"";RANG(B2;$B$2:$B$5))
puis pour les 2 autres mets un SIERREUR
=SIERREUR(INDEX($A$2:$A$5;EQUIV(LIGNE()-1;$C$2:$C$5;0));"")

Cdlmnt
Commenter la réponse de via55
Messages postés
22
Date d'inscription
mardi 19 février 2019
Statut
Membre
Dernière intervention
10 avril 2019
0
Merci
Merci beaucoup, tous fonctionne comme je le voulais !!!!
Commenter la réponse de JulienHch