Menu

Je n'arrive pas à afficher mon bandeau en HTML

-
Bonjour,
Je suis en terminale s, j'ai un site Internet à réaliser pour ma spé ISN. Seulement, je suis confronté à un problème: j'ai appliqué votre méthode pour que le bandeau s'affiche mais cela n'a pas fonctionné. Je vous envoie les lignes de codes.
Merci par avance de l'aide que vous me porterez !!

Voilà les lignes de codes HTML
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "//www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999xhtml"xml:lang="fr">
 
 <head>
   <meta charset="utf-8" />
   <title>L'univers du job</title>
   <link rel="stylesheet" type="text/css" href="style_css.css">
 </head>
 <body>
    
   <header>
     <div id="header"></div> 
     <img src="laptop.png" width="110px" height="110px">
    
   </header> 
     <h1> 
       <center>L'évolution des métiers du numérique !</center>        
     </h1>
     <h3> 
       <center>Le numérique est aujourd'hui devenu un pôle majeur de l'emploi dans le monde.</center>
     </h3>
   
  <center> <img src="louer-informaticien.jpg" border="5" alt"Deux informaticiens travaillant sur leur projet> </center>
 </body>
</html>

Et CSS
body{ 
margin:0px; 
} 
#header{ 
height:120px; 
background:black; 
}


EDIT : Ajout des balises de code



MERCI!!!!!!!!!!
Afficher la suite 

5 réponses

Meilleure réponse
Messages postés
25826
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
26 juin 2019
1666
1
Merci
Bonjour,
As tu vidé le cache de ton navigateur (à faire dès qu'on touche du css ou du javascript )?

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 46924 internautes nous ont dit merci ce mois-ci

Commenter la réponse de jordane45
1
Merci
Bonjour

Si ce que tu appelles le bandeau correspond à l'image laptop.png, je te fait remarquer que tu l'as mise en dehors du div id="header", puisqu'elle est après le </div>
Si tu parles de l'image louer-informaticien.jpg, tu l'as mal déclarée : il manque le = après le alt, et tu n'as pas mis les doubles quotes pour refermer le texte du alt

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 46924 internautes nous ont dit merci ce mois-ci

gabyMMI
Messages postés
28
Date d'inscription
samedi 16 février 2019
Statut
Membre
Dernière intervention
4 juin 2019
-
Je n'ai toujours pas de bandeau.
Utilisateur anonyme -
Alors je répète ma question : ton fichier style_css.css s'appelle-t-il bien style_css.css (et pas style-css.css par exemple) et est-il bien dans le même dossier que ta page html ?
Peux-tu donner le contenu complet de ce fichier ?
gabyMMI
Messages postés
28
Date d'inscription
samedi 16 février 2019
Statut
Membre
Dernière intervention
4 juin 2019
-
Je m'en veux, je pensais que le "style_" était une commande, mais grâce à vous j'ai compris parce qu'on ne avait rien expliqué en cours. Merci beaucoup et je suis vraiment désolé de vous avoir dérangé autant de temps. Merci infiniment pour tous Monsieur!!!!!!!!!!! Grâce à vous j'ai compris et réussi à faire apparaître ce foutu bandeau!!!!!!!
Il n'y a pas de "commandes" en HTML, il y a des balises. Et il existe bien une balise <style> Mais ce n'est qu'un des moyens de mettre du CSS dans une page; toi tu utilises la balise <link> qui permet de dire que le style se trouve dans un autre fichier.

Ta page a d'autres gros défauts, en particulier tu déclares que tu déclares dans le doctype que tu utilises du XHTML strict, alors que derrière tu utilises la syntaxe du HTML 5. Tes balises DOCTYPE et HTML devraient être :
<!DOCTYPE HTML>
<html lang="fr">


Et il ne faut pas être désolé de nous déranger, les gens qui te répondent ici le font parce qu'ils veulent bien.

Bonne chance pour la suite et n'hésite pas à revenir :-)

Tu dois avoir quelque part vers le haut de la page une commande pour signaler que le sujet est résolu.
gabyMMI
Messages postés
28
Date d'inscription
samedi 16 février 2019
Statut
Membre
Dernière intervention
4 juin 2019
-
Merci encore de vos conseil, ça m'a énormément aidé surtout que je veux faire concepteur et designer web!!
Merci et bonne chance à vous aussi!! :-)
Bon week-end et je n'hésite pas à revenir vers si besoin! Heureusement qu'il y a des gens comme vous!
Commenter la réponse de Utilisateur anonyme
Messages postés
23217
Date d'inscription
samedi 22 octobre 2005
Statut
Modérateur
Dernière intervention
20 juin 2019
1630
1
Merci
si je comprends bien les images sont au même 'niveau' que le fichier html ?
tu devrais aussi mettre ici le contenu de " <link rel="stylesheet" type="text/css" href="style_css.css"> "
:)

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 46924 internautes nous ont dit merci ce mois-ci

gabyMMI
Messages postés
28
Date d'inscription
samedi 16 février 2019
Statut
Membre
Dernière intervention
4 juin 2019
-
Vous voulez dire quoi par au même niveau?
Et vous voulez mon code css?

Ohlala je dérange tout le monde pour un petit truc :(
gabyMMI
Messages postés
28
Date d'inscription
samedi 16 février 2019
Statut
Membre
Dernière intervention
4 juin 2019
-
Le problème est résolu et merci tout de même de votre intervention!!!!
Commenter la réponse de bg62
0
Merci
Oui je l'ai vidé, mais après avoir faire le html et le css.
jordane45
Messages postés
25826
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
26 juin 2019
1666 -
et donc... quel est le souci ?
car ce code semble fonctionner.....
Commenter la réponse de gabyMMI
Messages postés
28
Date d'inscription
samedi 16 février 2019
Statut
Membre
Dernière intervention
4 juin 2019
0
Merci
Le souci est que le bandeau ne s'affiche pas sur la page :D
Commenter la réponse de gabyMMI