Menu

Formule SI avec plusieurs intervalles [Résolu]

- - Dernière réponse :  Mika - 15 févr. 2019 à 16:47
Bonjour,

Je suis en train de bosser sur un tableau, dans lequel je veux mettre dans une cellule des résultats différents en fonction d'intervalles...
En gros, Si A1 est inférieur à 10 alors je multiplie le résultat par 65%, ensuite si A1 est dans l'intervalle 11 20 alors je multiplie par 80%, et pour finir si A1 est supérieur ou égal à 21 alors je multiplie par 88%

En fonction de A1 je souhaite que ma cellule calcul automatiquement le pourcentage...

Quelqu'un pourrait-il m'aider svp?
Merci d'avance

Configuration: Windows / Opera Next 57.0.3098.116
Afficher la suite 

Votre réponse

1 réponse

Messages postés
1757
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
24 mai 2019
612
0
Merci
Bonjour,

Suffit d'imbriquer les différents SI:
- =Si(A1<10;B1*0.65;Si(A1<20;B1*0.80;B1*0.88))

Avec B1 le résultat à multiplier.
Merci de me répondre si rapidement, cependant en essayant ta formule cela ne fonctionne pas.
diablo13800
Messages postés
1757
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
24 mai 2019
612 -
La formule fonctionne chez moi...

Il faudrait savoir ou sont vos différente valeur ( a multiplier et autre) pour que je puise faire mieux.

Vous pouvez, si vous le souhaitez, m'envoyer votre fichier via ce site :
http://cjoint.com

et en collant le lien en réponse
https://www.cjoint.com/c/IBppHAu8sdv

Merci beaucoup
diablo13800
Messages postés
1757
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
24 mai 2019
612 -
Bonjour,

Vous n'avez pas vraiment suivi ce que je vous ai dis comme formule:)

Voici votre formule corrigé:
=SI(A2<=59000;A2*0,65;SI(A2<=149000;A2*0,8;A2*0,88))
Super!!! Merci beaucoup, ça fonctionne nikel!
Commenter la réponse de diablo13800