Menu

Additionner selon plusieurs critères [Résolu]

Messages postés
86
Date d'inscription
lundi 27 février 2017
Statut
Membre
Dernière intervention
25 juin 2019
-
Bonjour à tous,

Dans le tableau "Qté totale", je souhaiterais additionner des cases respectant 2 critères :
- Respect de la semaine (WEEK01, WEEK02,...)
ET
- Respect de la référence entrée en B11.

Pour essayer de bien me faire comprendre, j'ai mis les résultats (en bleus, à côté du tableau) que l'on est censé obtenir pour la référence B.

Il me semblais que la formule à utiliser est SOMME.SI.ENS, mais je n'arrive pas à la faire fonctionner. Si quelqu'un pouvait m'aider ce serait sympa !

Merci
Afficher la suite 

3 réponses

Messages postés
24116
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 juin 2019
4641
0
Merci
Bonjour
SOMME.SI.ENS ne fonctionne qu'avec des données en colonne
si on se référe aux limites de votre image, essayez:
=SOMMEPROD($B$2:$I$2=A14)*($A$3:$I$9=$B$11)*($B$3:$I$9))
à tirer de B14 à B20
crdlmnt


Coco-8
Messages postés
86
Date d'inscription
lundi 27 février 2017
Statut
Membre
Dernière intervention
25 juin 2019
1 -
Merci de la réponse. Il y a pas une petite manipulation à faire pour valider les matrices quand on utilise cette formule ? Car en l'appliquant telle qu'elle est mise, elle ne fonctionne pas...
Vaucluse
Messages postés
24116
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 juin 2019
4641 -
une manipulation? non, mais des corrections, manque une parenthèse au début et il y a une erreur d'adresse dans le 2° item:
=SOMMEPROD(($B$2:$I$2=A14)*($A$3:$A$9=$B$11)*($B$3:$I$9))
avec mes excuses (je viens juste de me lever de la sieste!)
crdlmnt
Coco-8
Messages postés
86
Date d'inscription
lundi 27 février 2017
Statut
Membre
Dernière intervention
25 juin 2019
1 -
En effet ça marche mieux, merci ! Il reste juste un petit soucis, elle n'additionne pas entre elle les quantités des WEEK 03 A et WEEK 03 B (6 + 8). Surement à cause de décomposition de la semaine en A et B... Est-il possible de réajuster ça sans toucher à l'intitulé des cases ?
Vaucluse
Messages postés
24116
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 juin 2019
4641 -
essayez de corriger le 1°item (($B$2:$I$2=A14) comme suit:

=((GAUCHE($B$2:$I$2;7)=A14).......
crdlmnt
Commenter la réponse de Vaucluse
Messages postés
9005
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
25 juin 2019
1590
0
Merci
Bonjour à tous les deux

Un petit bug dans la formule de Vaucluse (que je salue au passage)
=SOMMEPROD(($B$2:$I$2=A14)*($A$3:$A$9=$B$11)*($B$3:$I$9))
qu'il a corrigée en se levant de la sieste ;-)

Et pour ta dernière remarque
=SOMMEPROD((GAUCHE($B$2:$I$2;7)=A14)*($A$3:$A$9=$B$11)*($B$3:$I$9))

Cdlmnt
Coco-8
Messages postés
86
Date d'inscription
lundi 27 février 2017
Statut
Membre
Dernière intervention
25 juin 2019
1 -
Parfait c'est exactement ce que je voulais! Merci à vous deux !
Commenter la réponse de ccm81
Messages postés
86
Date d'inscription
lundi 27 février 2017
Statut
Membre
Dernière intervention
25 juin 2019
1
0
Merci
Me revoilà sur ce sujet, j'aimerais encore un peu de votre aide pour améliorer mon fichier.



Le tableau en jaune est le tableau corrigé avec les valeurs que je souhaite obtenir avec une fonction. Grâce à vos aides, j'ai déjà réussi à obtenir la quantité totale et les quantités standards (c'est à dire WEEK 01, WEEK 02, WEEK 03,...) et désormais j'aimerais obtenir les quantités FR (WEEK N FR) et PT (WEEK N PT).

Merci
Commenter la réponse de Coco-8