Menu

Faire une somme avec chiffre et lettre

- - Dernière réponse : Vaucluse
Messages postés
24073
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
16 juin 2019
- 14 févr. 2019 à 13:03
Bonjour je souhaite faire une somme des chiffres contenant aussi des lettres.
Par exemple additionner :
5 jours
2 jours
3 jours
.....

Et avoir comme somme : 10 jours.

Merci de votre aide.
Afficher la suite 

2 réponses

Meilleure réponse
Messages postés
24073
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
16 juin 2019
4624
1
Merci
Bonjour
si c'est pour afficher Jours dans les cellules, il est plus simple de formater piur conserver la valeur numérique
ainsi par exemple:
clic droit, format de cellule , personnalisé
et dans le cadre type, inscrivez:
standard" jours"
la cellule affiche jours derrière le nombre entré et conservera sa valeur numérique pour des calculs ultérieurs

sinon vous pouvez utiliser une formule matricielle pour sommer des valeurs qui se trouveraient toutes à gauche du 1° blanc dans les cellules, soit par exemple pour un champ de A2àA30:

=SOMME(GAUCHE(A2:A30;TROUVE(" ";A2:A30))*1)

attention, formule matricielle à entrer avec la touche enter en maintenant les touches ctrl et shift enfoncées. (elle doit s'afficher automatiquement entre accolades dans la barre de formule)

crdlmnt

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 42528 internautes nous ont dit merci ce mois-ci

Commenter la réponse de Vaucluse
Messages postés
1930
Date d'inscription
mercredi 27 juillet 2005
Statut
Membre
Dernière intervention
31 mai 2019
744
0
Merci
Bonjour,

Tu peux essayer :
=SOMME(--GAUCHE(AG11:AG13;1))
ou
=SOMME(--GAUCHE(AG11:AG13;TROUVE(" ";AG11:AG13)-1))

à valider par CTRL+MAJ+ENTER

cordialement
Commenter la réponse de JvDo