Menu

Demande d'aide formule si [Résolu]

Messages postés
9
Date d'inscription
jeudi 14 février 2019
Dernière intervention
14 février 2019
- - Dernière réponse : Vaucluse
Messages postés
23477
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 février 2019
- 14 févr. 2019 à 14:23
Bonjour,
je ne suis pas très à l'aise sur excel et je cherche une formule "si" avec condition que la somme soit 1 si la case n'est pas vide (du texte dans les cases) ou s'il n' y a pas écrit "à faire". J'ai en effet des colonnes avec du texte "date" pour indiquer quand le document a été reçu et du texte "a faire" quand ce n'est pas le cas. les résultats seront ensuite convertis en pourcentage
Pouvez vous m'aider ?
Cordialement,
Mélie
Afficher la suite 

Votre réponse

2 réponses

Meilleure réponse
Messages postés
1583
Date d'inscription
jeudi 2 juillet 2015
Dernière intervention
14 février 2019
519
1
Merci
Bonjour,

Il vous faut être un peu plus précise:
- Quels sont les valeurs possibles pour votre case de test?
- Quels valeurs doivent ressortir en cas de test concluant?
- Et en cas de tests négatifs?

Je vous invite également à envoyé votre fichier via ce site : http://cjoint.com
et a communiquer le lien en réponse

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 58763 internautes nous ont dit merci ce mois-ci

Vaucluse
Messages postés
23477
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 février 2019
5622 -
voyez ce modèle qui reprend votre demande de A16 à A60
et si ce n'est pas ce que vous attendez, expliquez nous ce que vous voudriez obtenir avec c e modèle:
https://mon-partage.fr/f/B5y2bctL/
melie81
Messages postés
9
Date d'inscription
jeudi 14 février 2019
Dernière intervention
14 février 2019
-
merci, je vois, mais si je ne veux pas créer de colonne à droite, c'est peut être une formule de type si.somme.ens que je dois écrire pour que le total se répercute au bas de cette colonne avec les cellules remplies ou vide?
Vaucluse
Messages postés
23477
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 février 2019
5622 -
Ca dépend de ce que vous voulez compter
si c'est uniquement compter le nombre de cellules en A qui contiennent autre chose que "à faire" et qui ne sont pas vides, la formule dans la cellule verte du modèle fera l"affaire sans utiliser la colonne B
Pour utiliser SOMME.SI.ENS, il faut avoir un champ de valeurs à sommer, ,lequel dans votre cas?
melie81
Messages postés
9
Date d'inscription
jeudi 14 février 2019
Dernière intervention
14 février 2019
-
Merciiiiiiiiiiiiii :) j'ai enfin réussi, avec la formule verte, merci de votre patience, je suis soulagée !!
bon courage
Mélie
Vaucluse
Messages postés
23477
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 février 2019
5622 -
Pas de quoi
je passe le sujet en résolu
Bonne route
crdlmnt
Commenter la réponse de diablo13800
Messages postés
23477
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 février 2019
5622
1
Merci
Bonjour
allez, je tente
avec en A2 la date en B2 le texte
=SI(ET(A1<>"";B1="à faire");1;"")*
  • que vous pouvez calculer directement sans colonne intermédiaire avec:

=NB.SI.ENS(A2;"<>";B2;"à faire")
et si ça ne va pas, remettez vous en à notre ami diablo (salut) en déposant votre fichier
crdlmnt

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 58763 internautes nous ont dit merci ce mois-ci

Vaucluse
Messages postés
23477
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 février 2019
5622 -
je rectifie suite à votre dernier message:

=SI(OU(B2="";B2="à faire");0;1)

et pour un calcul direct:
=NB.SI.ENS(B:B;"<>";B:B;"<>à faire")

crdlmnt
diablo13800
Messages postés
1583
Date d'inscription
jeudi 2 juillet 2015
Dernière intervention
14 février 2019
519 -
Salut Vaucluse:)

On arrive au même conclusion à 3 minute près c'est rassurant
Commenter la réponse de Vaucluse