Menu

Application d'un forfait en fonction d'une date

Messages postés
4
Date d'inscription
vendredi 12 avril 2013
Dernière intervention
12 février 2019
- - Dernière réponse : eriiic
Messages postés
22426
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 février 2019
- 12 févr. 2019 à 13:52
Bonjour à tous,

Je recherche une solution pour appliquer un forfait en fonction d'une date.

Je dois payer des journées (grande ou petite) et je dois leur appliquer un forfait en fonction de date.

Date | P | G
01-07-16 | 20€ | 40€
01-07-17 | 25€ | 50€
01-10-18 | 30€ | 60€
01-01-19 | 35€ | 70€

Le problème majeur est que ça ne s'applique pas à date fixe mais plutôt entre date.

Exemple :
ce qui est compris entre le 01/07/2016 et le 30/06/2017 est à 20 €
ce qui est compris entre le 01/07/2017 et le 30/09/2018 est à 25 €

Pour le moment, je me suis débrouillé avec des SI imbriqués mais là pour rajouter 2019 ça devient très compliqué.
J'ai essayé avec RECHERCHEV ou INDEX EQUIV ou FREQUENCE mais sans grand résultat, je suis un peu bloqué.

Y-a-t-il une fonction (je ne les connais pas toutes) qui permettrait de faire ce genre de chose, de rechercher entre deux dates pour renvoyer un résultat ?

Je joins un fichier avec les infos.

https://www.cjoint.com/c/IBmlbJcAP2T

J'espère que qqn pourra m'aider.

Merci d'avance,

Anthony
Afficher la suite 

Votre réponse

3 réponses

Messages postés
137
Date d'inscription
samedi 2 février 2019
Dernière intervention
22 février 2019
15
0
Merci
Bonjour,
pour la valeur 20€ :

=SI(ET(A7>=01/07/2016;A7<=30/06/2017);"20€";"")

Pour la valeur 25€ :

=SI(ET(A7>=01/07/2017;A7<=30/09/2018);"25€";"")

Pour combiner les 2 :

=SI(ET(A7>=01/07/2016;A7<=30/06/2017);"20€";"")&SI(ET(A7>=01/07/2017;A7<=30/09/2018);"25€";"")
kenci177
Messages postés
4
Date d'inscription
vendredi 12 avril 2013
Dernière intervention
12 février 2019
-
Je fais déjà des SI à répétition c'est ce que je veux éviter mais merci.
Commenter la réponse de Yoyo01000
Messages postés
22426
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 février 2019
7216
0
Merci
Bonjour,

=B2*INDEX(DECALER($H:$H;;C2="Grande";);EQUIV(A2;$G:$G;1)) 

Le 01/01/2016 retourne #N/A car cette date est exclue de ton tableau, il commence au 01/07/2016.
J'ai aussi modifié la colonne mois où tu y faisais un calcul inutile.
https://www.cjoint.com/c/IBml0ct74i6
eric
Commenter la réponse de eriiic
Messages postés
4
Date d'inscription
vendredi 12 avril 2013
Dernière intervention
12 février 2019
0
Merci
En théorie, il ne devrait plus y avoir de date en dessous du 01/01/2016 donc ta réponse me convient bien.

Encore merci.
eriiic
Messages postés
22426
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 février 2019
7216 -
Sinon tu complètes ton tableau, la formule n'y est pour rien et ne change pas.
Commenter la réponse de kenci177