Menu

VM Debian et droit d'accès lors de la création de fichiers ou de répertoires

Messages postés
19707
Date d'inscription
samedi 17 mars 2007
Statut
Contributeur
Dernière intervention
13 février 2019
- - Dernière réponse : _Ritchi_
Messages postés
19707
Date d'inscription
samedi 17 mars 2007
Statut
Contributeur
Dernière intervention
13 février 2019
- 11 févr. 2019 à 18:46
Bonjour,

Sur un PC Windows 7, j'utilise une VM Linux Debian.
Note: Ce n'est pas moi qui l'ai installée, donc je ne saurais pas trop en parler. Je n'en suis qu'un utilisateur.
Dans mon environnement informatique, j'ai accès à un disque réseau.
Je l'ai monté dans Windows 7 et j'y accède en lecture / écriture sans souci.
Je l'ai monté dans la VM Debian via le fichier
/etc/fstab
en ajoutant une ligne de ce style:
<file system> <mount point> <type> <options> <dump> <pass>
<adresse IP du disque> /mnt/Images ext4 defaults 0 2

Le souci que je rencontre est un souci de droits d’accès aux fichiers ou aux répertoires.
En effet, selon qu'ils ont été créés depuis l'interface graphique de la VM Debian ou depuis le Terminal Linux ou depuis ma session Windows 7, ils n'ont pas les mêmes droits. Par exemple, ma session Windows 7 peut les voir mais pas les modifier. Je dois alors retourner dans la VM Debian et faire un
chmod 777 * 
, voire même dès fois faire un
chown localuser.localuser *
(localuser étant le compte utilisateur dans la VM Debian). Ensuite, je peux modifier un fichier ou le contenu d'un répertoire depuis ma session Windows 7.

Quand je crée un fichier ou un répertoire depuis le Terminal Debian, j'ai un peu amélioré les choses en mettant le umask à 000: ainsi les droits d'un fichier créé depuis le Terminal sont 666 (rw-rw-rw-) et ceux d'un répertoire sont 777 (rwxrwxrwx), ce qui me permet les modifications depuis mas session Windows 7.

Question:
Que faire pour que la création de fichiers ou de répertoires via l'interface graphique Debian me permette d'avoir les droits 666 pour le fichier et 777 pour le répertoire ?

En espérant avoir été clair,
Ritchi
Afficher la suite 

Votre réponse

2 réponses

Messages postés
36158
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
11 février 2019
5821
0
Merci
Salut,
Je l'ai monté dans la VM Debian via le fichier
/etc/fstab
en ajoutant une ligne de ce style :
<file system> <mount point> <type> <options> <dump> <pass>
<adresse IP du disque> /mnt/Images ext4 defaults 0 2

Je suppute que c'est le defaults dans ta ligne qui t'empêche de faire ce que tu veux ;-(

Jette un oeil aux options disponibles ;-)

Commenter la réponse de zipe31
Messages postés
19707
Date d'inscription
samedi 17 mars 2007
Statut
Contributeur
Dernière intervention
13 février 2019
4918
0
Merci
Bonjour,
Merci pour ce lien où j'ai découvert qu'on pouvait définir umask dans les options.
Alors j'ai testé avec defaults,umask=000:
adresse_IP_disque:/vol/vol1/sharedDisk  /sharedDisk  nfs   defaults,umask=000  0  2

Résultat: le disque n'est même plus monté.
Aurais-tu une idée des paramètres à mettre ?

Ritchi
PS: l'interface graphique dans la VM est XFCE
zipe31
Messages postés
36158
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
11 février 2019
5821 -
À partir du moment où tu rajoutes des options, mieux vaut éviter l'option "defaults" ;-\

Regarde quelques exemples, avec notamment
gid=xxx,uid=xxx
de spécifier…
_Ritchi_
Messages postés
19707
Date d'inscription
samedi 17 mars 2007
Statut
Contributeur
Dernière intervention
13 février 2019
4918 -
J'ai tenté plein de combinaisons de paamètres, mais seule la combinaison avec "defaults" tout court marche.
:-(
J'abandonne sauf si tu as une autre idée
Merci de ton support
Ritchi
Commenter la réponse de _Ritchi_