Menu

Multi-amorcage disque non monté

Messages postés
14
Date d'inscription
jeudi 6 décembre 2018
Dernière intervention
13 février 2019
- - Dernière réponse :  uPriiw_ - 13 févr. 2019 à 12:26
Bonjour à tous ! J'ai actuellement un problème sur mon ordinateur ( en fait c'est une machine virtuelle , mais je ne pense pas que ça change grand chose ). J'ai un multi-amorcage pour Windows 10 , Ubuntu 18.04 et Deepin. Windows 10 et Ubuntu son sur mon disque 1 , et Deepin sur mon disque 2. Deepin étant le dernier système que j'ai installé , c'est donc depuis Deepin que le grub se lance et peut se configurer. Le problème est que je peux seulement démarrer Deepin. Si j'essaye de démarrer un autre système , j'ai ce message qui s'affiche : https://imgur.com/G0somm0

J'ai remarqué qu'en passant par le BIOS , et en appuyant sur "démarrer normalement" ( boot normally )( https://imgur.com/sM7mzbL ) , ce qui me met également le menu grub de Deepin , je peux accèder à ninporte quel système. Je suppose donc ceci :

Le disque 1 n'est pas monté au démarrage , seulement le disque 2 sur lequel Deepin est contenu. l'erreur vient de la. En ouvrant le BIOS , tout les disques se montent automatiquement , ce qui règle le problème... jusqu'au prochain redémarrage

Est-ce que mon raisonnement est bon ? Et dans tout les cas ,comment faire pour régler le problème ?

Merci d'avance de vos réponses !!
Afficher la suite 

Votre réponse

5 réponses

Meilleure réponse
1
Merci
Salut,

Le message dit que la partition EFI CCC1-649B n'existe pas, et donc que le fichier de boot de Windows n'est pas trouvé. Un rapport boot-info depuis Ubuntu en dirait plus.

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 58732 internautes nous ont dit merci ce mois-ci

iTrooz_
Messages postés
14
Date d'inscription
jeudi 6 décembre 2018
Dernière intervention
13 février 2019
-
Comment faire un rapport boot-info ?

je tiens également à repréciser que le grub est "hébergé" sur Deepin , faut-il donc vraiment le faire sur Ubuntu ?
Si deepin sait gérer boot-info, pourquoi pas. Mais Ubuntu le fait très bien, et tout sera écrit, de toute manière.

https://doc.ubuntu-fr.org/tutoriel/boot-info#installation
Commenter la réponse de uPriiw_
Messages postés
14
Date d'inscription
jeudi 6 décembre 2018
Dernière intervention
13 février 2019
0
Merci
J'ai fait le rapport boot-info : http://paste.ubuntu.com/p/frVsDz4J4w/
Laisse moi un moment pour le lire... un triple boot, ça complique un peu.
Bon, c'est un peu sac de noeuds tout ça, car il y a des incohérences d'uuid, étrangement pas dans le grub de deepin, mais celui d'ubuntu. On le voit ici :

========================= sda1/EFI/ubuntu/grub.cfg: ===========================
--------------------------------------------------------------------------------
search.fs_uuid b40fab3f-1904-4eea-8050-fd9437df48c2 root hd1,gpt3
set prefix=($root)'/boot/grub'
configfile $prefix/grub.cfg
--------------------------------------------------------------------------------

Cette uuid n'existe pas, ce que montre blkid.

Le fichier suivant est également bizarre car on a l'impression qu'il a été modifié à la main :

=========================== sda4/boot/grub/grub.cfg: ===========================

Par exemple, certaines zones sont différentes d'un fichier traditionnel, et on voit des guillemets doubles à la place de guillemets simples.... Bizarre.

En revanche, le démarrage de deepin semble tout à fait correct. Pour que je puisse comprendre mieux le souci, essaie de faire une photo du grub qui fonctionne, et une du grub qui bugue. Car spontanément, j''aurais plutôt accusé le grub d'ubuntu que celui de deepin.
iTrooz_
Messages postés
14
Date d'inscription
jeudi 6 décembre 2018
Dernière intervention
13 février 2019
-
Deepin à un grub "special" , c'est à dire que les options sont affichées d'une autre manière que dans le grub de Ubuntu. Je peux donc dire sans screens et sans aucun doute que les deux grubs ( avant & après le passage dans le BIOS ) sont exactement les mêmes , et c'est le grub généré par deepin. Le grub ubuntu est celui "de base" ( fond noir , options enhaut à gauche ) et je ne l'ai jamais.

Si ca peut aider , j'ai touché aux deux grubs avec grub-customizer ( juste pour modifier les noms des entrées , pour essayer de comprendre )
Et tu as le problème depuis ou tu l'avais auparavant ?

Tu vas faire deux tests

- depuis ton bios-uefi , tu fais un essai direct sur chacune des trois entrées (deepin, ubuntu, windows boot manager), à tour de rôle. Tu me dis ce qui fonctionne et ce qui échoue.

- Puis, lorsque tu as ton GRUB qui conduit à une erreur, tu choisis e sur l'entrée windows, et tu fais une photo de ce qui s'affiche.

Selon ce que tu me diras, on verra ce qu'il est préférable de faire.
Commenter la réponse de iTrooz_
Messages postés
14
Date d'inscription
jeudi 6 décembre 2018
Dernière intervention
13 février 2019
0
Merci
J'ai installé les 3 OS sur ma machine virtuelle directement d'un coup , donc il n'y avait pas vraiment de "avant".
J'arrive à me connecter sur les trois depuis le BIOS , Ubuntu me renvoi vers son grub , deepin aussi , et Windows... bah sans grub mais il marche ^^

Si j'essaye de démarrer sur Windows ( si je démarre sur Ubuntu avec erreur il m'envoit directement sur le BIOS , ce qui règle le problème ) , j'ai ce message : https://imgur.com/G0somm0

N'y aurait-il pas un moyen de monter tout les disques au démarrage ? Je pense que le problème vient de la étant donné que si je met le grub ubuntu par défaut , le seul OS qui ne marche pas est Deepin
Commenter la réponse de iTrooz_
Messages postés
14
Date d'inscription
jeudi 6 décembre 2018
Dernière intervention
13 février 2019
0
Merci
( Je tiens à préciser que le problème viens effectivement du fait que les partitions ne soient pas montées au démarrage , je viens de vérifier dans le fichier /etc/fstab . Je vais essayer de modifier le fichier pour monter les partitions au démarrage , mais je suis pas sûr de la démarche à suivre )
Commenter la réponse de iTrooz_
0
Merci
J'aimerais bien comprendre une fois pour toutes (je ne parviens pas à décrypter ce qu'il se passe réellement).

J'arrive à me connecter sur les trois depuis le BIOS , Ubuntu me renvoi vers son grub , deepin aussi , et Windows... bah sans grub mais il marche

Atteindre grub n'est pas une finalité. C'est ce qui se passe après qui importe. Prenons le cas de chaque option dans le BIOS à tour de rôle (corrige-moi si je me trompe).

1. Ubuntu : il doit fonctionner jusqu'au GRUB. Mais si tu choisis "l'entrée Ubuntu", il doit forcément planter. Les autres entrées Windows et Deepin de son grub doivent peut-être fonctionner, mais pas sûr.
2. Windows boot manager: il doit lancer Windows directement, sans aucune intervention.
3. Deepin: il lance son grub lui aussi. Les trois OS (Deepin, Windows, ubuntu) devraient fonctionner... ou deepin uniquement. Là, je n'en sais rien.

Si j'essaye de démarrer sur Windows ( si je démarre sur Ubuntu avec erreur il m'envoit directement sur le BIOS , ce qui règle le problème ) , j'ai ce message : https://imgur.com/G0somm0

Cette phrase n'a strictement aucun sens. En tout cas, elle contredit celle-ci : Windows... sans grub mais il marche.

On peut monter toutes les partitions, mais tu vas avoir un léger souci avec les partitions efi. Et dans un dualboot, on ne monte que la partition efi, la racine et le home de la distribution en cours. Monter les autres n'est pas indispensable.

En revanche, il y a en effet quelque chose de particulier dans la gestion des uuid avec deepin (il utilise non pas les uuid mais les partuuid : on le voit dans le second blkid et dans efibootmgr, et le problème vient sûrement de là), mais je veux d'abord comprendre ce qui fonctionne et ce qui ne fonctionne pas. Et ce n'est toujours pas clair. Je suis peut-être stupide, mais c'est ainsi.

Je vais te donner un conseil, puisque tu es sur PC virtuel. Supprime ou formate le disque sdb complètement. Boote sur Ubuntu. Et là, on fera déjà le point sur le dual boot Ubuntu /Windows. Il devrait planter. On le réparera, et quand ce sera bon pour ces deux-la, on ajoutera Deepin que tu auras réinstallé. Et si le GRUB de Deepin ne fonctionne pas, on utilisera celui d'Ubuntu provisoirement, jusqu'à comprendre comment fonctionnent les uuid sous Deepin.
iTrooz_
Messages postés
14
Date d'inscription
jeudi 6 décembre 2018
Dernière intervention
13 février 2019
-
j'ai réessayé , et la même erreur :/ avec en bonus "le noyau doit d'abord être chargé" , je ne crois pas que ca y était avant ( Grub Ubuntu avec l'entrée Deepin , sans passer par le BIOS )
Alors, à ce stade, ça veut dire que les modifs ont été bien prises en compte, mais que le grub d'Ubuntu a un problème dans son paramétrage. On voit exactement le même problème entre Ubuntu et Manjaro.

Il me faut donc un nouveau rapport boot-info (depuis ubuntu) pour qu'on voie quelle ligne pose souci. Je vais me décider à reproduire ta situation de mon côté afin de tirer tout ça au clair.
Je viens de réaliser une installation identique (partition efi sur sdb). J'ai même une configuration plus tordue, puisque j'ai fedora, et un lancer refind en plus. Bilan, tout fonctionne directement.

Ci-joint le rapport boot-info fait depuis un live-cd.

http://paste.ubuntu.com/p/d4gCMms5VD/

Mes uuid sont bonnes, contrairement à chez toi.
iTrooz_
Messages postés
14
Date d'inscription
jeudi 6 décembre 2018
Dernière intervention
13 février 2019
-
Je pourrais savoir dans quel ordre tu as installé les systèmes ? Moi j'ai fait Windows , Ubuntu , Deepin
Pas de Windows... Il n'a pas d'importance puisque le souci vient de GRUB. Pour résumer :

Disque sda : un dual-boot déjà ancien Mint / Fedora (installé dans cet ordre) géré par une partition efi en sda1. J'ai fait en sorte de réparer GRUB pour que les deux versions fonctionnent : j'ai expliqué ça ici : http://ikewdu.free.fr/dual-boot-mintubuntu-avec-fedora-en-uefi/ . C'est un dual-boot déjà ancien que j'ai réutilisé pour la circonstance.

Disque sdb : ajouté hier, une version récente de deepin. Pour avoir une seconde partition efi en sdb1 (comme toi), j'ai dû partitionner manuellement (pourquoi ce choix?), et le seul problème rencontré ensuite, c'est la mise en page graphique de GRUB que j'ai dû reparamétrer à la main.

Bilan :

- ça boote automatiquement sur deepin (le dernier installé, c'est normal) et il parvient à lancer les 3OS sans aucune intervention (seul le graphisme de Fedora est perdu, ce qui est normal puisque le GRUB est hérité de debian, et donc j'ai le même bug qu'avec Mint).
- Si je choisis l'entrée Deepin dans le BIOS, c'est exactement pareil. Tout se lance directement.
- Si je choisis l'entrée ubuntu dans le bios, je n'ai pas Deepin, ce qui est normal. Mais après un sudo update-grub, l'entrée est ajoutée, et là aussi, tout fonctionne parfaitement après redémarrage.

Le rapport boot-info résume tout cela.

Un conseil: refais ton installation proprement ; tu testes progressivement, et surtout tu agis sans cette daube qu'est Grub-customizer.
Commenter la réponse de uPriiw_