Menu

Formule excel [Résolu]

- - Dernière réponse :  Nhyatus - 9 févr. 2019 à 11:55
Bonjour

je souhaite que la somme en A4 soit dispatcher selon le tableau si dessous



. A B C D
1
2
3 0 à 35 36 à 43 44 et +
4 45,00 ? ? ?
5
6

Les réponse doivent comme si dessous

. A B C D
1
2
3 0 à 35 36 à 43 44 et +
4 45,00 35 8 2
5
6
. A B C D
1
2
3 0 à 35 36 à 43 44 et +
4 33 33 0 0
5
6



. A B C D
1
2
3 0 à 35 36 à 43 44 et +
4 38 35 3 0
5
6

. A B C D
1
2
3 0 à 35 36 à 43 44 et +
4 0 0 0 0
5
6



MERCI de votre aide pour la formule des cellules B4 C4 et D4
Bonne soirée
Afficher la suite 

Votre réponse

5 réponses

Meilleure réponse
Messages postés
1398
Date d'inscription
lundi 28 janvier 2008
Dernière intervention
21 février 2019
338
1
Merci
salut désolé mais je ne comprend pas tout ce que tu veux faire

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 56678 internautes nous ont dit merci ce mois-ci

Commenter la réponse de votre psychiatre
0
Merci
Bonjour

J'ai dans une case un résultat disons
B4

Ce résultat doit être réparti dans trois colonnes

Si le résultat de B4 est moins ou égal à 35 colonne C et donc colonne D = 0 Colonne E = 0
Si le résultat de B4 est supérieur à 35
Colonne C mettre 35 et dans la collone D le résultat qui sera entre 36 et 43 et dans la colonne E le résultat super à 44 sinon 0

Donc
dans colonne C il doit avoir au maxi 35
Dans colonne D il doit avoir au maxi 8 ou 0 si C inférieur à 35
Dans colonne E le solde de ou 0 si B4 est inférieur à 44

Et si j additionne C D E le total = B

J'espère être plus clair
MERCI
Commenter la réponse de Nhyatus
Messages postés
1398
Date d'inscription
lundi 28 janvier 2008
Dernière intervention
21 février 2019
338
0
Merci
il faut partir de ton calcul
B4=si("toncalcul"<=35;"toncalcul";)
0...
oups je suis trop novice dans excel je ne comprends pas
Commenter la réponse de votre psychiatre
Messages postés
23535
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 février 2019
5636
0
Merci
Bonjour

si vous avez en B4
=SOMME(A1:A4)

en C4:(entre 8 exclus et 35 inclus)
=SI(ET(B4>8;B4<=35);B4;0)

en D4: (plus petit ou égal à 8
=SI(B4<=8;B4;0)

en E4 (plus grand que 44)
=SI(B4>=44;B4;0)


mais vous pouvez passer directement de A à D en remplaçant tous les b4 par le calcul sans passer par C
=SI(ET(SOMME(A1:A4)>8;SOMME(A1:A4)<=35);SOMME(A1:A4);0)
=SI(SOMME(A1:A4)<=8;SOMME(A1:A4);0)
=SI(SOMME(A1:A4)>=44;SOMME(A1:A4);0)

crdlmnt



Vaucluse
Messages postés
23535
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 février 2019
5636 -
ici:
http://mon-partage.fr
et revenez coller l lien à créé sur le site
si possible, rajouter au clavier quelques exemples de résultats attendus sur les 3 colonne
voilà merci


https://mon-partage.fr/f/Lv7TY2hq/
https://mon-partage.fr/f/Lv7TY2hq/

https://mon-partage.fr/admin/Lv7TY2hq/JeidRgLB/
Vaucluse
Messages postés
23535
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 février 2019
5636 -
Votre fichier en retour
normal que vous n'y arriviez pas, la vraie question n'est pas tout à fait celle que vous avez, posée!
revenez si ce n'est pas ce que vous attendez
https://mon-partage.fr/f/59DO0sns/
crdlmnt
MERCI
je vais vais faire quelques test mais tout me semble en ordre

comme toujours des réponses à mes questions

MERCI MERCI

Bonne journée à toutes et à tous
Commenter la réponse de Vaucluse
Messages postés
1398
Date d'inscription
lundi 28 janvier 2008
Dernière intervention
21 février 2019
338
0
Merci
alors ca donne ceci
L26=SOMME(H19:H24)
M26=SI(L26>=35;35;L26)
N26=L26-M26
O26=SI(ET(L26>35;L26<44);L26-35;SI(L26>43;8;))
P26=SI(L26>43;L26-43;)
Q26=M26+O26+P26

ça à l'air de fonctionner
dis moi
Commenter la réponse de votre psychiatre