Menu

Onglet et date automatique

- - Dernière réponse :  Gustav - 8 févr. 2019 à 15:55
Bonjour à tous et un grand merci pour votre aide.
Ma question qui parait simple :
Dans une version excel 2011, j'ai un onglet nommé Janvier.
Je souhaiterais que toutes les dates rentrées sur cette même page se mettent automatiquement
au 01/01/2020.
On peut aussi imaginer la même chose pour février, mars, ...
1000 merci pour votre aide
Gustav
Afficher la suite 

Votre réponse

4 réponses

Messages postés
104
Date d'inscription
samedi 2 février 2019
Dernière intervention
16 février 2019
11
0
Merci
Bonjour,
2 solutions :

Mettre 01/01/2020 dans une cellule et tirer vers le bas

Mettre la formule dans par exemple A1 : =SI($B1<>"";"01/01/2020";"")
(dès que tu rentres une valeur en B1, la date 01/01/2020 s'ajoute automatiquement en A1)
Formule à tirer vers le bas aussi.
Commenter la réponse de Yoyo01000
Messages postés
15674
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
16 février 2019
3607
0
Merci
Bonjour

Dans une cellule quelconque de la feuille "janvier" ou "février" ou "mars "
=("1/"&EQUIV(STXT(CELLULE("filename";A1);TROUVE("]";CELLULE("filename";A1))+1;32);{"janvier";"fevrier";"mars"};0)&"/2020")*1
à mettre au nombre format- date

avec
STXT(CELLULE("filename";A1);TROUVE("]";CELLULE("filename";A1))+1;32)

renvoie le nom de la feuille

mais tu pourrais alléger en faisant un tableau dans une feuille "param" avec la liste des mois par exemple A1:A12 nommée " liste" pour remplacer {janvier;février; mars...}


michel_m
Messages postés
15674
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
16 février 2019
3607 -
Maintenant si tes feuilles se suivent mois par mois(janvier, février, mars, avril), tu n'as pas besoin de écrire à nouveau cette "petite" formule
tu as la fonction:
Mois.decaler
Commenter la réponse de michel_m
0
Merci
Un grand merci à mon génie d'excel!
Ça marche Nickel!!!
C'est exactement ce que je voulais
Merci à toi et bonne fin de journée
Gustav
Commenter la réponse de Gustav
0
Merci
Un grand merci à toi pour ta réponse positive. Mais à l'usage je me rend compte que ta proposition ne correspond pas exactement à mes attentes. Vraiment désolé mais tu as fait surement très bien.
En fait, je voulais dans une feuille et un onglet nommés JANVIER, que toute date écrite sous la forme
01/01/2020 grâce aux touches ctrl + ; par exemple, me donne automatiquement cette date, et non pas, comme tu les proposes, date déclenchée par une valeur par exemple.
Encore merci pour tes efforts
Gustav
Commenter la réponse de Gustav