Menu

Focntion SOMMPROD (et EQUIV) avec condition

Messages postés
3
Date d'inscription
vendredi 8 février 2019
Dernière intervention
11 février 2019
-
Bonjour,

Ne maitrisant pas assez les fonctions SOMMPROD et EQUIV, je sollicite de l'aide ici.
Par avance merci :)


Onglet ROBE :

Via la fonction SOMMPROD, j’ai pu comptabiliser le nombres de références présentes à la fois dans ma colonne A (Magasin) et dans ma colonne B (INTERNET).

=SOMMEPROD(--(ESTNUM(EQUIV(B2:B15;A2:A15;0))))

Cela fonctionne bien, je trouve bien 11.



Onglet ROBE ET PANTALON :

A présent, j'aimerai comptabiliser la même chose mais en faisant le distinguo si la référence contient ROBE ou bien PANTALON.

Je ne sais pas où intégrer mon critère dans ma formule…


Les valeurs que je cherche à trouver sont en jaune dans l’onglet ROBE ET PANTALON.
-Je suis censée trouver 11 dans ROBE
-Et 0 dans PANTALON



J'ai un fichier que je peux mettre à disposition mais malheureusement je n’arrive pas à le joindre...

Merci d’avance.

CERE26
Afficher la suite 

Votre réponse

3 réponses

Messages postés
10238
Date d'inscription
mercredi 16 janvier 2013
Dernière intervention
18 février 2019
1313
0
Merci
Bonjour

Pour joindre un fichier tu le postes sur mon-partage.fr , tu fais créer un lien que tu coller et reviens coller ici

Cdlmnt
Via
"L'imagination est plus importante que le savoir."    A. Einstein
Commenter la réponse de via55
Messages postés
3
Date d'inscription
vendredi 8 février 2019
Dernière intervention
11 février 2019
0
Merci
Merci !

Voici : https://mon-partage.fr/f/oyD7NaZd/
Commenter la réponse de CERE26
Messages postés
10238
Date d'inscription
mercredi 16 janvier 2013
Dernière intervention
18 février 2019
1313
0
Merci
Re

Plus simple en rajoutant une colonne de comptage et des formules SOMME.SI
https://mon-partage.fr/f/98lFLoK3/

J'ai également mis des MFC pour colorer automatiquement en jaune les articles d'une colonne qu'on ne retrouve pas dans l'autre

Cdlmnt
Via
CERE26
Messages postés
3
Date d'inscription
vendredi 8 février 2019
Dernière intervention
11 février 2019
-
Merci, en effet comme ça tout fonctionne. La MFC est une très bonne idée pour contrôler. Merci à vous !
Commenter la réponse de via55