Menu

Comprise entre valeurs multiples

Messages postés
1
Date d'inscription
jeudi 7 février 2019
Dernière intervention
7 février 2019
-
Bonjour,



J'ai la formule suivante: =SI(ET(A1>10;A1<19);"toto";"tata"); disons que je voudrais ecrire tutu pour les valeurs entre 0 et 9, et titi pour celles entre 20 et 39, et tyty pour celles entre 40 et 80.

comment je dois m'y prendre?

Merci
Afficher la suite 

Votre réponse

2 réponses

Meilleure réponse
Messages postés
1844
Date d'inscription
lundi 3 mai 2010
Dernière intervention
15 février 2019
122
1
Merci
Bonsoir,

En général, pour ce genre de choses, on imbrique les SI :
=SI(ET(A1>0;A1<9);"tutu";SI(ET(A1>20;A1<39);"titi";SI(ET(A1>40;A1<80);"tyty";"")))

mais on peut aussi séparer les conditions :
=SI(ET(A1>0;A1<9);"tutu";"") & SI(ET(A1>20;A1<39);"titi";"") & SI(ET(A1>40;A1<80);"tyty";"")

ou trouver d'autres méthodes

A+

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 57876 internautes nous ont dit merci ce mois-ci

Commenter la réponse de Zoul67
Messages postés
22393
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
17 février 2019
7206
1
Merci
Bonjour,

ou bien :
=CHOISIR(EQUIV(A1;{0;10;20;40;80});"toto";"tata";"tutu";"tyty";"trop grand") 

eric

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 57876 internautes nous ont dit merci ce mois-ci

Commenter la réponse de eriiic