Menu

IMac mi 2007 : comment installer El Capitan ? [Résolu]

Messages postés
55
Date d'inscription
mercredi 16 septembre 2009
Dernière intervention
11 février 2019
-
Bonjour à tous,

J'aurais besoin de conseil concernant l'utilisation d'un iMac mi2007, 20 pouces, HDD de 250 Go, 4 Go de RAM, processeur Intel.

Il tourne actuellement sous Mac OS X Leopard (10.5.8).
Le propriétaire souhaite un OS plus récent car certaines appli fonctionnent mal dessus.
J'ai vu qu'on pouvait aller jusqu'à El Capitan avec cette machine. Mais je ne trouve aucun moyen de télécharger cet OS pour en faire une clé bootable. Apple ne le met à disposition qu'aux utilisateurs de certains de leurs systèmes comme Lion ou High Sierra...
Mais depuis une machine qui a déjà Mojave, téléchargement impossible. Et il me semble que c'était pareil avec le Leopard de cet iMac.

Quelqu'un m'a alors prêté son vieux DVD de Snow Leopard (pour éviter de le payer 20€ sur l'Apple Store). Est-ce que je pourrai l'installer sur l'iMac sans problèmes à la place de son Leopard, et est-ce que je pourrai ensuite faire la mise à niveau vers El Capitan ?

Est-ce que la démarche vous paraît correcte ?
En gros, quelle serait la meilleure option et qu'est-ce que vous me conseilleriez ? A noter qu'il n'exclut pas la possibilité de remplacer l'une de ses barrettes RAM de 2 Go avec une de 4 Go pour passer à 6 (référence DDR2 disponible chez Apple), voire si ça vaut le coup mettre un SSD.

J'ai déjà posé la question sur un autre forum mais plus j'ai d'avis, mieux c'est.

D'avance merci pour votre aide et votre expérience !



Configuration: Windows / Firefox 64.0
Afficher la suite 

Votre réponse

7 réponses

Messages postés
25288
Date d'inscription
jeudi 5 avril 2007
Statut
Contributeur
Dernière intervention
21 février 2019
5285
0
Merci
Bonsoir,

Si tu as posé ta question, sur d'autres forums Mac, tu auras eu de bonnes réponses, je n'en doute pas.
Oui, tu peux installer Snow Léopard à partir d'un disque universel de cet OS et non d'un disque fourni avec un autre Mac, qui comporterait Snow Léopard, celui-ci n'étant pas utilisable sur un autre Mac.
Après mise à jour vers Snow Léopard, et avoir monté la mémoire à 6 Go, maxi admis sur le modèle cité, tu vas sur cette page et tu suis les instructions de téléchargement.
Tu peux aussi passer par menu pomme/App Store/mise à jour de logiciel mais, ça ne fonctionne pas forcément.

Pour te créer une clé bootable, tu peux utiliser DiskMaker ou suivre les conseils donnés ici :
http://www.commentcamarche.net/faq/44770-creer-une-cle-usb-d-installation-os-x-10-11-alias-el-capitan

Simplement pour le cas où tu ne saurais pas faire :-)

Quand c'est urgent, il est déjà trop tard (Talleyrand)
Quand tout a échoué, lire le manuel ;)
Commenter la réponse de dede74000
Messages postés
55
Date d'inscription
mercredi 16 septembre 2009
Dernière intervention
11 février 2019
1
0
Merci
Génial, merci beaucoup d'avoir pris le temps pour cette réponse, je note ces détails.
Je m'intéresse à Apple et aux Mac OS depuis seulement quelques semaines, donc je découvre pas mal de nouveaux trucs encore et je ne connais pas tout par coeur. Merci pour les procédures ;)

Le Snow Leopard que j'ai sous la main est bien un DVD universel qui a été acheté à part. Je vais tenter le coup ce week-end ! Par contre l'upgrade en 6 Go de RAM ne se ferait à priori qu'un peu plus tard, il va donc continuer à fonctionner avec seulement 4 Go dans l'immédiat mais ça devrait passer quand même.
Commenter la réponse de Stranger_00
Messages postés
19718
Date d'inscription
samedi 17 mars 2007
Statut
Contributeur
Dernière intervention
21 février 2019
4939
0
Merci
Bonjour,

"...4 Go dans l'immédiat mais ça devrait passer quand même..." : certes, mais il va ramer !
Perso, j'ai le modèle iMac 24" mi-2007 sous El Capitan et avec 6Go, ce n'est pas très réactif.

Alors mon conseil:
- installe Snow Leopard avec le DVD
- fais la Mise à Jour Combinée 10.6.8 v1.1
- laisse le propriétaire tester si cela va mieux pour ses applications qui fonctionnent mal
- une possibilité est de migrer ensuite vers OS X 10.7 Lion (sorti en 2010-2012) ou OS X 10.8 Mountain Lion (sorti en 2012-2013) voir OS X 10.11 El Capitan (sorti en 2015-2016)


Surtout préviens le propriétaire qu'en passant à un système beaucoup plus récent comme ElCapitan, il prend l'énorme risque:
- de devoir mettre à jour toutes ses applications/jeux et donc les racheter si elles étaient payantes;
- de perdre des applications/jeux qui ne sont plus supportées par un système macOS X récent;
- de perdre les applications/jeux encodés PowerPC: à partir de macOS Lion 10.7, Apple a supprimé le support des applications non codées entièrement pour l'architecture Intel. La très discrète Rosetta qui se chargeait dans Leopard et Snow Leopard de transformer à la volée le code binaire d'architecture PowerPC en Intel n'a pas été incluse dans Lion par Apple.
- de devoir changer tout périphérique actuellement utilisé avec MacOS X Leopard (imprimante, scanner, etc.) si le constructeur du périphérique n'a pas fait l'effort d'adapter son pilote pour aux systèmes macOS plus récents.

Sois bien conscient de tout cela avant de te lancer dans l'aventure et laisse le propriétaire de cet iMac décider en toute connaissance de cause.

Ritchi
Commenter la réponse de _Ritchi_
Messages postés
55
Date d'inscription
mercredi 16 septembre 2009
Dernière intervention
11 février 2019
1
0
Merci
Bonjour !

C'est ok, tout s'est bien passé.
D'abord l'installation de Snow Leopard avec le DVD universel (environ 1h d'installation).
Ensuite combo update pour passer de 10.6 à 10.6.8.
Et ensuite téléchargement sur l'Apple Store de El Capitan depuis le lien direct de dede74000 (2-3 heures de téléchargement en Ethernet) et installation (1 heure de plus).

L'iMac tourne donc actuellement dessus et tout semble ok !
Par contre comme j'ai lancé l'installation depuis l'OS à chaque fois (plutôt qu'en bootant dessus), j'ai l'impression qu'il a plus fait une mise à niveau qu'une vraie nouvelle installation. Mais c'est tout de même un résultat très satisfaisant.

Merci encore pour ces conseils :)
_Ritchi_
Messages postés
19718
Date d'inscription
samedi 17 mars 2007
Statut
Contributeur
Dernière intervention
21 février 2019
4939 -
Et côté applications/jeux/imprimante/scanner/... : tu as vérifié si le propriétaire allait retrouver quelque chose ?
Stranger_00
Messages postés
55
Date d'inscription
mercredi 16 septembre 2009
Dernière intervention
11 février 2019
1 > _Ritchi_
Messages postés
19718
Date d'inscription
samedi 17 mars 2007
Statut
Contributeur
Dernière intervention
21 février 2019
-
Il n'y avait pas encore grand-chose dessus à part un fond d'écran car il a obtenu cet iMac récemment (c'est pour ça que je n'avais pas pris le temps de faire une sauvegarde avant les nouvelles installations de MacOS X). Mais c'est une très bonne remarque, je vais essayer de vérifier.
Commenter la réponse de Stranger_00
Messages postés
55
Date d'inscription
mercredi 16 septembre 2009
Dernière intervention
11 février 2019
1
0
Merci
Oh, j'ai posté ma réponse sans avoir vu que _Ritchi_ avait posté avant moi. Je comprends mieux ta question. C'est pour ça que je suis venu me renseigner ici avant en fait, pour savoir s'il y avait des contre-indications ou d'autres choses à savoir :)
J'ai fait cette installation samedi en début d'après-midi.

Merci pour toutes ces remarques très détaillées et précises que je note dans un coin. Je vais essayer de savoir si tout est ok.

Le contexte était le suivant : le propriétaire venait de récupérer l'iMac après que quelqu'un le lui ait cédé car n'en ayant plus l'utilité. Il l'a donc récupéré "vidé", mais tournant quand même sur Leopard et avec une session administrateur déjà existante (j'ai dû créé un nouveau compte au passage car ils n'avaient pas le mot de passe Admin de l'autre).
Il n'y avait donc pas de fichiers ou de logiciels spécifiques dessus, à part à priori quelques photos nouvellement copiées sur le disque.
Le propriétaire se plaignait parce qu'avec un OS aussi ancien et un Safari obsolète, il n'arrivait pas à faire des choses basiques comme lire des vidéos sur Youtube par exemple.

Peut-être que Snow Leopard aurait suffi, ou alors Lion ou encore Mountain Lion.. Là il fonctionne avec El Capitan et je n'ai pas eu de retour négatif depuis ce week-end. Mais je vais informer le propriétaire de tout cela. Il n'a toujours que 4 Go de RAM mais m'a dit avoir commandé 2 barrettes de 2 Go (j'espère qu'il ne s'est pas trompé de référence) car il m'a assuré qu'il y avait 4 slots à l'intérieur alors que je pensais qu'il n'y en avait que 2.
Commenter la réponse de Stranger_00
Messages postés
55
Date d'inscription
mercredi 16 septembre 2009
Dernière intervention
11 février 2019
1
0
Merci
En fait, il veut aller encore plus loin car il m'a parlé de vouloir remplacer la carte-mère de cette machine avec une plus récente pour pouvoir mettre Mojave dessus... J'avoue que dans l'immédiat je n'ai aucune idée sur la faisabilité de la chose.
Commenter la réponse de Stranger_00
Messages postés
19718
Date d'inscription
samedi 17 mars 2007
Statut
Contributeur
Dernière intervention
21 février 2019
4939
0
Merci
Bonjour,

Si il a vraiment un iMac mid-2007, alors il n'y a que deux slots de mémoire et pour avoir le maximum de mémoire, soit 6Go, il lui faut une barrette de 2Go plus une barrette de 4Go de ce modèle: 200-pin PC2-5300 (667MHz) DDR2 SO-DIMM

Concernant la carte mère qu'il veut changer pour avoir un système Mojave, dis lui qu'il rève. Cet iMac étant déclaré obsolète par Apple depuis quelques années déjà, les cartes mères sont rares et au mieux, il en trouvera une un peu plus rapide au niveau processeur, mais il n'empêche que son iMac+nouvelle carte mère sera toujours refusé par les serveurs d'Apple pour passer au delà de El Capitan.

El Capitan lui conviendra très bien: j'ai cette version et je ne me sens pas bloqué pour faire de la vidéo (avec Final Cut Express et iMovie), si ce n'est une lenteur dans les traitements. Aussi, je les lance avant de me coucher et le lendemain, ils sont finis.

Si tu veux te préparer à démonter son iMac mi-2007, voici un excellent site: https://fr.ifixit.com/Device/iMac_Intel_20%22_EMC_2133_and_2210

Ritchi
Commenter la réponse de _Ritchi_