Menu

RECHERCHEV AVEC CONDITION

Messages postés
12
Date d'inscription
lundi 25 mars 2013
Dernière intervention
7 février 2019
- - Dernière réponse : nigloo06
Messages postés
12
Date d'inscription
lundi 25 mars 2013
Dernière intervention
7 février 2019
- 7 févr. 2019 à 15:19
Bonjour,

J'ai actuellement deux tableaux dans deux onglets différents.

Tableau 1 : NOM / DATE DE DEBUT / DATE DE FIN (le meme nom apparaît sur plusieurs lignes avec des dates différentes)
Tableau 2 : NOM / DATE DE DEBUT / DATE DE FIN / DATE D ABSENCE

J'aimerais ramener la date de debut et de fin en fonction du nom si la date d'absence est comprise entre la date de debut et de fin.

Est ce que quelqu'un peut m'aider ?
Afficher la suite 

Votre réponse

6 réponses

Meilleure réponse
Messages postés
10273
Date d'inscription
mercredi 16 janvier 2013
Dernière intervention
22 février 2019
1318
1
Merci
Bonjour

Rien compris !!
Poste un exemple de ton fichier sur mon-partage.fr, fais créer un lien que tu copies et reviens coller ici en donnant un exemple précis d'un cas à traiter

Cdlmnt
Via

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 56243 internautes nous ont dit merci ce mois-ci

Commenter la réponse de via55
Messages postés
1165
Date d'inscription
lundi 23 juillet 2012
Dernière intervention
7 février 2019
204
1
Merci
Bonjour,

Dans la feuil2, chaque ligne contient une colonne telle que
=SI(ET(D2>B2;D2<C2);"o";"n")


Ensuite, dans la feuil1, 2, 3 et 5 sont respectivement les colonnes "date déb" "date fin" et "compris entre"
Date déb :
=SI(RECHERCHEV(A2;Feuil2!A:E;5)="o";RECHERCHEV(A2;Feuil2!A:D;2);"")

Date fin :
=SI(RECHERCHEV(A2;Feuil2!A:E;5)="o";RECHERCHEV(A2;Feuil2!A:D;3);"")

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 56243 internautes nous ont dit merci ce mois-ci

Commenter la réponse de tuxboy
Messages postés
10273
Date d'inscription
mercredi 16 janvier 2013
Dernière intervention
22 février 2019
1318
1
Merci
Si tu ne postes pas un exemple de ton fichier on ne pourras pas t'aider

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 56243 internautes nous ont dit merci ce mois-ci

nigloo06
Messages postés
12
Date d'inscription
lundi 25 mars 2013
Dernière intervention
7 février 2019
-
Je vous ai mis un lien j'espère que ça fonctionne
Commenter la réponse de via55
Messages postés
12
Date d'inscription
lundi 25 mars 2013
Dernière intervention
7 février 2019
0
Merci
Bonjour,

Merci de vos retours.

https://mon-partage.fr/f/Jq0hmvfs/

Voilà le lien :)
Commenter la réponse de nigloo06
0
Merci
Bonjour,

Comme cela : https://www.cjoint.com/c/IBhnZXiS8xk

A te relire
Commenter la réponse de FoufouParis
Messages postés
12
Date d'inscription
lundi 25 mars 2013
Dernière intervention
7 février 2019
0
Merci
Merci de votre retour mais cela ne correspond pas à mon besoin, pour le nom A il faut qu'il me ramène la date de debut et de fin en fonction de la date d'absence.

Par exemple pour le NOM A il faudrait qu'il me ramène cela avec la date d'absence qui est comprise entre la date de début et de fin.

NOM DATE DEBUT DATE FIN ABSENCE
A 30/02/2019 30/06/2019 15/04/2019
A 01/01/2019 25/02/2019 15/01/2019
Commenter la réponse de nigloo06