Menu

Question sur un mélange de "si" et de" et " [Résolu]

Messages postés
1942
Date d'inscription
lundi 14 mars 2011
Dernière intervention
20 février 2019
- - Dernière réponse : flexi2202
Messages postés
1942
Date d'inscription
lundi 14 mars 2011
Dernière intervention
20 février 2019
- 7 févr. 2019 à 11:40
bonjour a tous
je souhaite crée des conditions avec des "si" et des "et "

qui pourrait ressembler a ceci
mais toutes ces conditions dans une seule ligne
merci de l aide

si A1 ="voiture particuliere" et B1 ="2 chgt" alors en C1 =15 mmm
si A1 ="voiture particuliere" et B1 ="4 chgt" alors en C1 =30 mmm
si A1 ="voiture particuliere" et B1 ="2 perm" alors en C1 =10 mmm
si A1 ="voiture particuliere" et B1 ="4 perm" alors en C1 =15 mmm
si A1 ="suv" et B1 ="2 chgt" alors en C1 =15 mmm
si A1 ="suv" et B1 ="4 chgt" alors en C1 =30 mmm
si A1 ="suv" et B1 ="2 perm" alors en C1 =10 mmm
si A1 ="suv" et B1 ="4 perm" alors en C1 =15 mmm
si A1 ="4*4" et B1 ="2 chgt" alors en C1 =20 mmm
si A1 ="4*4" et B1 ="4 chgt" alors en C1 =45 mmm
si A1 ="4*4" et B1 ="2 perm" alors en C1 =10 mmm
si A1 ="4*4" et B1 ="4 perm" alors en C1 =20 mmm
si A1 ="grosse cylindres" et B1 ="2 chgt" alors en C1 =20 mmm
si A1 ="grosse cylindres" et B1 ="4 chgt" alors en C1 =45 mmm
si A1 ="grosse cylindres" et B1 ="2 perm" alors en C1 =10 mmm
si A1 ="grosse cylindres" et B1 ="4 perm" alors en C1= 20 mmm
si A1 ="camionette" et B1 ="2 chgt" alors en C1= 20 mmm
si A1 ="camionette" et B1 ="4 chgt" alors en C1 =45 mmm
si A1 ="camionette" et B1 ="2 perm" alors en C1= 10 mmm
si A1 ="camionette" et B1 ="4 perm" alors en C1 =20 mmm
Afficher la suite 

Votre réponse

5 réponses

Meilleure réponse
Messages postés
135
Date d'inscription
samedi 2 février 2019
Dernière intervention
21 février 2019
15
1
Merci
Bonjour,

voici la formule correspondant à la première ligne :
=SI(ET($A1="voiture particulière";$B1="2 chgt");"15 mmm";"")

Il te suffit de rajouter les conditions souhaitées entre ""

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 56682 internautes nous ont dit merci ce mois-ci

Commenter la réponse de Yoyo01000
Messages postés
135
Date d'inscription
samedi 2 février 2019
Dernière intervention
21 février 2019
15
1
Merci
=SI(ET($A1="voiture particulière";$B1="2 chgt");"15 mmm";"")&SI(ET($A1="voiture particulière";$B1="4 chgt");"30 mmm";"")&SI(ET($A1="voiture particulière";$B1="2 perm");"10 mmm";"")&SI(ET($A1="voiture particulière";$B1="4 perm");"15 mmm";"")...

tu rajoutes & à chaque fois, tout simplement :)

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 56682 internautes nous ont dit merci ce mois-ci

Commenter la réponse de Yoyo01000
Messages postés
1942
Date d'inscription
lundi 14 mars 2011
Dernière intervention
20 février 2019
61
0
Merci
bonjour merci pour la reponse
dans cet exemple je les imbriques comment

=SI(ET($A1="voiture particulière";$B1="2 chgt");"15 mmm";"")
=SI(ET($A1="voiture particulière";$B1="4 chgt");"30 mmm";"")
SI(ET($A1="voiture particulière";$B1="2 perm");"10 mmm";"")
SI(ET($A1="voiture particulière";$B1="4 perm");"15 mmm";"")
Commenter la réponse de flexi2202
Messages postés
1942
Date d'inscription
lundi 14 mars 2011
Dernière intervention
20 février 2019
61
0
Merci
merci pour la reponse mais j ai une erreur #valeur en C1
Yoyo01000
Messages postés
135
Date d'inscription
samedi 2 février 2019
Dernière intervention
21 février 2019
15 -
en A1, la syntaxe est paticuliere ou particulière ? (e avec ou sans accent)
flexi2202
Messages postés
1942
Date d'inscription
lundi 14 mars 2011
Dernière intervention
20 février 2019
61 -
merci pour la reponse
voiture particulière avec accent
flexi2202
Messages postés
1942
Date d'inscription
lundi 14 mars 2011
Dernière intervention
20 février 2019
61 -
pour etre sur de ne pas me tromper j ai fait un copier coller
flexi2202
Messages postés
1942
Date d'inscription
lundi 14 mars 2011
Dernière intervention
20 février 2019
61 -
ah je reviends de copier la colle et cela fonctionne
Yoyo01000
Messages postés
135
Date d'inscription
samedi 2 février 2019
Dernière intervention
21 février 2019
15 -
Sujet résolu alors !

Content d'avoir pu t'être utile :)
Commenter la réponse de flexi2202
Messages postés
1942
Date d'inscription
lundi 14 mars 2011
Dernière intervention
20 février 2019
61
0
Merci
voila cela fonctionne a merveille
un tout grand merci
pour cette aide
Commenter la réponse de flexi2202