Menu

Compter les valeurs uniques sur une plage

Messages postés
8
Date d'inscription
lundi 4 février 2019
Dernière intervention
5 février 2019
- - Dernière réponse : michel_m
Messages postés
15697
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
23 février 2019
- 6 févr. 2019 à 08:50
Bonjour,


J'ai un tableau qui classifie des salariés en fonction de leur compétence (1 colonne = 1 compétence). Des salariés peuvent être à la fois dans plusieurs colonnes. J'ai besoin de comptabiliser le nombres de salariés sur plusieurs colonnes et de ne comptabiliser qu'une seule fois chaque nom.
J'ai taper la formule ci-dessous mais j'ai un message d'erreur. Une idée ?

=SOMME(SI(FREQUENCE(SI(LEN(D3:K33)>0;EQUIV(D3:K33;D3:K33;0);""); SI(NBCAR(D3:K33)>0;EQUIV(D3:K33;D3:K33;0);""))>0;1))

Nota : la première compétence est en colonne D et la dernière est en colonne K. J'ai des cellulles vides sur certaines colonnes.
Afficher la suite 

Votre réponse

10 réponses

Messages postés
15697
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
23 février 2019
3619
0
Merci
Bonjour,

Normalement, avec un tableau dynamique, ça devrait faire....
Commenter la réponse de michel_m
Messages postés
144
Date d'inscription
samedi 2 février 2019
Dernière intervention
23 février 2019
15
0
Merci
Bonjour,
voici un exemple de formule :

=NB.SI($D1:$G2;"exemple")

$D1:$G2 étant ta plage de données et "exemple" le nom-prénom des personnes.

Formule à mettre à côté de ta plage de données.

Si ça te convient !?
Commenter la réponse de Yoyo01000
Messages postés
8
Date d'inscription
lundi 4 février 2019
Dernière intervention
5 février 2019
0
Merci
Merci Yoyo1000. Je check si fonctionne et vous réponds. Pour Michel_m je ne vois pas bien comment réaliser avec un dynamique....
Commenter la réponse de Nosler3645
Messages postés
8
Date d'inscription
lundi 4 février 2019
Dernière intervention
5 février 2019
0
Merci
Yoyo01000 la formule indiqué ne fonctionne pas. Ci-dessous ce que j'ai mis.
=NB.SI($D1:$G33;"exemple1""exemple2""exemple3")
Je rappelle que l'objectif est de compter le nombre de noms en ne comptant qu'une fois les doublons.
Merci de votre aide
Yoyo01000
Messages postés
144
Date d'inscription
samedi 2 février 2019
Dernière intervention
23 février 2019
15 -
normal que cela ne fonctionne pas ! ta syntaxe de formule ne peut aller !
donc si un nom apparaît (plusieurs fois ou pas) dans la plage de données de compétence, tu veux qu'il ressorte ou et de quelle manière ?

Si j'ai bien compris, si "nom1" est dans la plage de données, tu veux que "nom1" s'affiche dans une cellule et "nom2" dans une autre, etc ?
Nosler3645
Messages postés
8
Date d'inscription
lundi 4 février 2019
Dernière intervention
5 février 2019
-
Je me suis donc mal exprimé. Pardon !
Le fichier exemple - une extraction du fichier réel - donne des noms de personne en fonction des compétences. 1 colonne = 1 compétence. Je peux avoir une même personne dans plusieurs colonnes.
Si je compte simplement le nombre de cellules non vide sur la plage je compterai à chaque fois les doublons.
Donc je dois compter tous les noms et faire en sorte de n'avoir compter qu'une fois les doublons. De plus le nombre de personne par compétences variant je dois pouvoir inclure - sans les compter - les cellules vides.
Suis-je clair ce coup-ci ?
Commenter la réponse de Nosler3645
Messages postés
15697
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
23 février 2019
3619
0
Merci
Re,
sans ton classeur, je ne peux rien tenter pour tester un TCD....


Commenter la réponse de michel_m
Messages postés
8
Date d'inscription
lundi 4 février 2019
Dernière intervention
5 février 2019
0
Merci
Comment joindre un fichier dans le sujet ?
Commenter la réponse de Nosler3645
Messages postés
8
Date d'inscription
lundi 4 février 2019
Dernière intervention
5 février 2019
0
Merci
j'ai déposer le fichier. Il est consultable à l'adresse suivante :
https://www.cjoint.com/c/IBfoaXZ1dfw
Commenter la réponse de Nosler3645
Messages postés
144
Date d'inscription
samedi 2 février 2019
Dernière intervention
23 février 2019
15
0
Merci
col A col B col C
1 << Vide
2 Jean Jean Liste
3 Pierre Pierre Jean
4 Jean Jean Pierre
5 Pierre Pierre Louis
6 Louis Louis André
7 Jean Jean
8 Jean Jean
9 André André
10 Jean Jean
11 Louis Louis
12 Pierre Pierre
13 André André

En C3 :
{=INDEX($A:$A;MIN(SI(NB.SI(C$2:C2;$A$2:$B$40)=0;LIGNE($A$2:$B$40))))&""}

(plage de données de la formule à modifier)

formule matricielle à valider par Ctrl+Maj+Entrée
Nosler3645
Messages postés
8
Date d'inscription
lundi 4 février 2019
Dernière intervention
5 février 2019
-
Merci YoYo01000. Oui et non.
Oui car tu as trouvé 4 noms
Non car je dois convertir ces noms en 1 nombre. En l'occurrence 4.
Donc soit je passe par ta formule puis après je compte les NBVIDE ou bien est-ce que la formule peux être modifiée ?
Commenter la réponse de Yoyo01000
Messages postés
15697
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
23 février 2019
3619
0
Merci
Téléchargment refusé !







Nosler3645
Messages postés
8
Date d'inscription
lundi 4 février 2019
Dernière intervention
5 février 2019
-
Du coup ce lien là fonctionne t-il ?
https://1drv.ms/x/s!AtIHHvq1Jmdoga8zJpFySLAuzOenuw

J'ai mis le fichier en partage sur OneDrive.
Commenter la réponse de michel_m
Messages postés
15697
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
23 février 2019
3619
0
Merci
Bonjour,

Merci pour la pièce jointe

Nombre d'intervenants:

=SOMMEPROD(SI(D3:K33<>"";1/NB.SI(D3:K33;D3:K33)))

Formule matricielle à valider par « ctrl+maj+entrée » (et non directement par « entrée »), le curseur clignotant dans la barre de formule. La formule est alors encadrée automatiquement par des accolades : { formule }
Commenter la réponse de michel_m