Menu

Aucun peripherique trouvé

Messages postés
12
Date d'inscription
mercredi 10 octobre 2018
Statut
Membre
Dernière intervention
26 janvier 2019
- - Dernière réponse :  golfri - 29 janv. 2019 à 00:21
Bonjour, j'ai Kde linux sur mon pc, je voulais installer lamp pour faire du php, l'ayant donc fait, ensuite apres j'ai supprimé les dossiers apache, php, phpmyadmin se trouvant dans le repertoire lib et j'ai aussi supprimé le dossier www.
Puis j'ai redemarré mon systeme, lorsque le bureau s'affiche, je mets une video, on me dit aucun peripherique audio trouvé.
De plus, lorsque je partage la connexion de mon telephone avec mon pc, je tape une recherche sur firefox, on m'affiche aucune connexion internet, et pourtant je suis bien connecté.
Et enfin, mon systeme a ralenti, c a d que mes applis s'ouvrent lentement maintenant.
Aidez moi s'il vous plait
Afficher la suite 

Votre réponse

2 réponses

Meilleure réponse
Messages postés
28815
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
19 mai 2019
6554
1
Merci
Bonjour,

Si tu veux désinstaller un logiciel, il ne faut pas supprimer à la main un répertoire, car tu risques de supprimer plus que ce qu'il faut. Un logiciel s'installe/se met à jour/se désinstalle via le la logithèque ou via commandes apt, etc...).

Ensuite, ce que tu racontes est un peu confus. Par exemple le dossier contenant les sites web est
/var/www
et donc n'a rien à voir avec
/var/lib
, ce sont deux dossiers indépendants et je ne vois pas comment supprimer l'un a pu supprimer l'autre. Charcuter
/var
est extrêmement dangereux. C'est là qu'est stocké l'état du système. C'est un peu comme si tu allais directement dans la base de registre sous windows.

Ces répertoires n'ont par ailleurs aucun rapport avec les symptômes que tu observes.

J'ai l'impression que tu as meilleur temps de réinstaller ubuntu. Mais si tu veux tenter une réparation, la seule solution que je vois est de réinstaller les paquets installés sur ta machine en espérant reconstruire les bouts que tu n'aurais pas dû supprimer.

Sans conviction, tu peux essayer les commandes suivantes, à taper dans un terminal :

sudo apt-get update
sudo apt-get install aptitude
sudo aptitude upgrade
sudo aptitude reinstall $(dpkg -l | grep ^ii | cut -d" " -f3)


Si la dernière commande ne marche pas car il y a trop d'arguments, essaye à la place :

for x in $(dpkg -l | grep ^ii | cut -d" " -f3); do sudo aptitude reinstall $x; done


Bonne chance

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 39169 internautes nous ont dit merci ce mois-ci

Commenter la réponse de mamiemando
0
Merci
@mamiemando,

Je suis très loin d'avoir tes connaissance en informatique et je fais pleins de boulettes que je dois réparer ensuite.
La dernière est d'avoir supprimé des fichiers importants du système, mon Linuxmint ne voulait plus redémarrer.
N'étant pas doué pour les lignes de commande, j'ai utilisé ma clé linuxmint.
Bon, c'est de la bricole mais comme j'avais Timeshift d'installé, j'ai copié en mode root dans etc/timesfift les fichiers manquants que j'ai collé là ou ils devaient être. Je suis sur que je ne suis pas le 1er à le faire mais comme c’était en mode Euréka, j''en suis plutôt fier..lol
Peut être que le truc peut fonctionner pour le cas de JoanWill si timeshift était installé et qu'il s’exécutait.

Salut.
Commenter la réponse de golfri