Cellule avec matricielle [Résolu]

Messages postés
353
Date d'inscription
samedi 7 décembre 2013
Statut
Membre
Dernière intervention
15 juin 2019
- - Dernière réponse : guismo33
Messages postés
353
Date d'inscription
samedi 7 décembre 2013
Statut
Membre
Dernière intervention
15 juin 2019
- 26 janv. 2019 à 11:49
Bonjour à tous,

j'ai une cellule matricielle dans A1 et je voudrais faire une opération dans B1 , mais cela ne fonctionne pas " affiche erreur " je ne peut faire de calcul ou autre , car la cellule est matricielle.

peut être une idée ?


bien à vous
Afficher la suite 

4 réponses

Messages postés
15936
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
20 octobre 2019
2813
0
Merci
Bonjour,

Une idée? peut-^tre si tu tu es plus précis dans ta demande!

au strict minimum, nous montrer cette formule avec le classeur téléchargé

Mettre le classeur sans données confidentielles en pièce jointe sur
https://mon-partage.fr
Dans lien de téléchargement
faire un clic droit- copier l’adresse du lien et le coller dans votre message en cours sur ccm



guismo33
Messages postés
353
Date d'inscription
samedi 7 décembre 2013
Statut
Membre
Dernière intervention
15 juin 2019
1 -
Bonjour ,


j'ai une colonne avec plusieurs nombre et j'utilise cette matricielle en A1 pour enlever les doublons.

{INDEX($T:$T;MIN(SI(NB.SI($V1:V2;$T$4:$T$35)=0;SI(ESTNUM($T$4:$T$35);LIGNE($T$4:$T$35)))))&""}

puis en A3 je demande la position du nombre placée en P1:T1 avec cette formule :

=SIERREUR(EQUIV(W55;$P$1:$T$1;0);"")

Problème, il marque une erreur sur cellule car elle est en matricielle , auriez vous la solutions ?

merci à vous


bien à vous
Commenter la réponse de michel_m
Messages postés
7834
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
20 octobre 2019
1227
0
Merci
Bonjour,

Ma boule de cristal n'arrive pas à lire ta formule.
Je doute fort que le texte exact du message d'erreur soit « je ... »
guismo33
Messages postés
353
Date d'inscription
samedi 7 décembre 2013
Statut
Membre
Dernière intervention
15 juin 2019
1 -
Bonjour ,

j'ai une colonne avec plusieurs nombre et j'utilise cette matricielle en A1 pour enlever les doublons.

{INDEX($T:$T;MIN(SI(NB.SI($V1:V2;$T$4:$T$35)=0;SI(ESTNUM($T$4:$T$35);LIGNE($T$4:$T$35)))))&""}

puis en A3 je demande la position du nombre placée en P1:T1 avec cette formule :

=SIERREUR(EQUIV(W55;$P$1:$T$1;0);"")

Problème, il marque une erreur sur cellule car elle est en matricielle , auriez vous la solutions ?

merci à vous


bien à vous
Patrice33740
Messages postés
7834
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
20 octobre 2019
1227 -
Quel message d'erreur ??????????
guismo33
Messages postés
353
Date d'inscription
samedi 7 décembre 2013
Statut
Membre
Dernière intervention
15 juin 2019
1 -
re,

#N/a
Patrice33740
Messages postés
7834
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
20 octobre 2019
1227 -
#N/A n'est pas à proprement dit une erreur mais plutôt une réponse normale qui signifie
« l'information à chercher, n'a pas été trouvée »
ça n'a aucune rapport avec le fait que la formule soit matricielle.
guismo33
Messages postés
353
Date d'inscription
samedi 7 décembre 2013
Statut
Membre
Dernière intervention
15 juin 2019
1 -
Bonjour patrice,

je joins un fichier, merci à vous
https://mon-partage.fr/f/7OK3v2oy/

bien à vous
Commenter la réponse de Patrice33740
Messages postés
15936
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
20 octobre 2019
2813
0
Merci
A mon avis, il me semble que les matricielles ne fonctionnent pas des colonnes entieres
guismo33
Messages postés
353
Date d'inscription
samedi 7 décembre 2013
Statut
Membre
Dernière intervention
15 juin 2019
1 -
bonjour michel,

ci joint petit fichier, merci à vous

https://mon-partage.fr/f/7OK3v2oy/



bien à vous
DjiDji59430
Messages postés
2485
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
11 octobre 2019
278 -
Bonjour aux 2

en w3 =sierreur(EQUIV(INDIRECT("W"&COLONNE(B:B));$P$1:$R$1;0);"")

Crdlmt
guismo33
Messages postés
353
Date d'inscription
samedi 7 décembre 2013
Statut
Membre
Dernière intervention
15 juin 2019
1 -
merci djidji
Commenter la réponse de michel_m
Messages postés
7834
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
20 octobre 2019
1227
0
Merci
Bonjour,

Peut-être :
matricielle :
{=SI(INDEX($T1:$T33;MIN(SI(NB.SI($V$2:V$2;$T$4:$T$33)=0;SI(ESTNUM($T$4:$T$33);LIGNE($T$4:$T$33)))))>0;INDEX($T1:$T33;MIN(SI(NB.SI($V$2:V$2;$T$4:$T$33)=0;SI(ESTNUM($T$4:$T$33);LIGNE($T$4:$T$33)))));"")}

et (non matricielle)
=SI(ESTNA(EQUIV(W2;$P$1:$R$1;0));"";EQUIV(W2;$P$1:$R$1;0))


Exemple :
https://mon-partage.fr/f/GLJlwHjV/




Cordialement
Patrice
guismo33
Messages postés
353
Date d'inscription
samedi 7 décembre 2013
Statut
Membre
Dernière intervention
15 juin 2019
1 -
re,

en te remerciant patrice , fonctionne très bien .

bien à vous
Commenter la réponse de Patrice33740